7

I've been using a WD 2TB HD for the last two months to handle my Time Machine backups for my Macbook Air. Yesterday, I wanted to set it up to handle backups through the network. In the Time Machine interface, I selected "Remove Disk" for this WD drive and confirmed "Stop Using This Disk" in the following confirmation. This confirmation states that "Your existing backups will not be deleted."

After playing around with the network setup, I found it wouldn't work to my needs and decided to just get the drive set back up with my laptop. After clicking "Select Backup Disk" and then "Use Disk" for the HD, it's as if that drive has never been used before. See screenshot below:

enter image description here

Furthermore, when entering into Time Machine, none of my backups appear in the UI. When browsing the drive through the Finder, the Time Machine files are still there, so I know that the data is not lost. I just can't access it.

What can I do to get everything back up and running again like it was before?

System info: Mavericks (10.9.1), MacBook Air 13" Mid 2011, Western Digital 2TB My Passport


Update 12/29/2013. Additional info: here is what I see when I click "Select Disk" again, after I've re-added the drive. As you can see, the drive appears twice, once as a Time Machine backup, and again as a regular drive.

Screenshot:

enter image description here


Update 12/30/2013. I am now able to access previous backups (by using Kent's recommendation of using option plus clicking the Time Machine menu bar icon), but the interface is so slow that it could appear to be not working if one wasn't patient enough. Something blocking on the main thread, perhaps?

The main issue to solve now is how to get incremental backups working from the last full backup made to the drive, instead of starting from scratch.

3
+100

To access the previous backups, press the option key when clicking on the time machine menu bar icon. You'll see an item to browse other time machine disks.

  • This is an awesome idea, but when I click browse and select the disk, it displays backups, but only the ones made after I had reconnected it, and not the ones created beforehand. EDIT: Actually, it seems I can view those backups, but they appear in a light pink font and I cannot select them. – Dan Loewenherz Dec 28 '13 at 15:36
  • Hmmm... I'm shooting in the dark now; but, there's an older thread on Apple's forums that suggests to first open a new finder window, navigate to the "Computer" (press command+shift+C), and then open Time Machine. I suspect this won't work in your case, but it's worth a shot. discussions.apple.com/message/15776109#15776109 is where I got that info. – Kent Dec 28 '13 at 22:46
  • Just tried it...I am now able to retrieve those prior backups! Now onto the question of whether Time Machine can start back with incremental backups from the pre-existing data instead of doing a full one. – Dan Loewenherz Dec 30 '13 at 23:21
  • 1
    You might check apple.stackexchange.com/questions/3096/… There is some information on a command-line hack that convinces the computer to use a specific disk (BackupAlias) as well as a link to a slightly easier (since 10.7) way that may do the same thing. I've not tried either method; but, it looks reasonable. – Kent Jan 2 '14 at 8:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .