4

The solutions described here and here are no longer available in the current version.

I am editing a document in Romanian but every word gets spell-checked in English.

enter image description here

  • 2
    Have you gone to Edit > Spelling and Grammar > Show Spelling and Grammar to set the dictionary to what you want? – Tom Gewecke Dec 23 '13 at 13:14
  • Yes. I think that is the correct way to do it, but Romanian isn't in the list and there is not a choice for 'Other'. The best thing to do is probably to turn off the spell checker (from Edit > Spelling and Grammar > Check Spelling While Typing (AND Correct Spelling Automatically). – Nelu Dec 23 '13 at 17:22
  • 1
    Sorry, I misread the question, you are right of course. The only other fix would be add a Romanian dictionary if you can find one. m10lmac.blogspot.com/2011/06/… – Tom Gewecke Dec 23 '13 at 17:45
  • How to set a language for the whole document should be in the Pages 5 help page but isn't. – Jano Feb 24 '15 at 11:58
3

This is actually an OS X issue and not a Pages issue since Pages uses the system dictionaries.

You can use this support article to find the answer:

You will see that Romanian spelling dictionary isn't something that ships with 10.11 - but you can add custom dictionaries under the spell check multiple language section at the bottom of the page.

  1. Open System Preferences on your Mac, click Keyboard, then click Text. (System Preferences is under the Apple menu at the top-left corner of your computer screen.)

  2. Choose Set Up from the Spelling pop-up menu.

  3. Do any of the following:

    • Drag the languages in the list into the order you want them checked.

    • Select the checkbox next to languages you want to be checked.

    • If you have a dictionary file you want to use, copy it to the Spelling folder in your Library folder.

The last option is what you need. You could start with a free dictionary and perhaps pay for a better one if you can't make a dictionary or locate/make a better free one.

The panel where you get instructions to add the Romanian (or other) files looks like this:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .