2

I recently installed OS Mavericks as Virtual Machine. Everything else is working fine. I got Xcode 5.0.1 ( and then tried Xcode 5.0.2) installed successfully. However, Xcode crashes everytime I create new project.

I go to File -> Project and select the template for new project. As soon as I enter the project name and hit the create button I get locked out of the Mac.

I then have to enter my password once again and start Xcode again. It does not open workspace at this point.

Surprisingly, it seems that all initial files are getting created. When I open Xcode after the crash I can go to File -> Open and then open the earlier created project. I am very new to iOS development and learning on my own reading books. I don't know if it is creating all the required files or not ?

  1. Can anyone please confirm if these all the files which need to be created for a page based application ? ( please see the screenshot ), also;
  2. Is there a remedy to this problem?

I tried https://stackoverflow.com/questions/19473231/xcode-5-crashes-on-new-project-creation however it does not work in my case.

enter image description here

2
  • Did you ever find a solution for this? I am having the same problem on VMware player 6, OSX Mavericks 10.9.4 and Xcode 5.1.1 and it crashes every time that I try to create a new file in Xcode (other applications seem to be fine) either using a new project or just adding new files to the existing project. – RobbZ Aug 12 '14 at 12:47
  • What virtual machine type and version is in use? What is the host OS (the client OS is OSX in this case..) – bmike Aug 12 '14 at 14:07
1

The same happened to me, when i was set name for new xcode project "SendTweet", it crashed while creating. But when restart my guest mac on windows the project created. Then i try to create project with different name, this time no problem, it worked.

Again I used a name "Tweetbot", This time again crashed. Just try to create with different project name, it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .