5

I'm trying to share my MacBook's files via Samba sharing. I've set it up in Settings, but can't connect to the machine from another computer!

On the other computer I set up the connection with the correct IP address, username and password. Then when I try to connect, it shows a dialog in which the server asks for password. Then I enter the correct password, and shows the dialog again and again. If I dismiss the dialog, the client shows a this message:

Logon failure: incorrect username and password

However I'm sure the username and password are correct. (If it matters, the client is just an android tablet with a samba client app. The same app handles Windows shares without any problem.)

Has anyone faced a similar problem?

My OS X version is Mavericks.

  • Hi, As a total pedant I'd like to point out that you are not using "Samba" sharing at all. The Apple SMB sharing does not use Samba. – Tony Williams Mar 6 '14 at 0:58
2

Samba passwords are managed separately from your regular account password. Have you set-up your user to enable samba sharing in the options menu? You need to do it once otherwise the login won't work.

In the File Sharing preference pane tick the checkbox next to the user you want to enable file sharing for and a window will pop-up asking you to authenticate.

As soon as this is done you should be able to login from your android tablet.

sharing preference pane

UPDATE

The root cause of the issue might be that 10.9 uses a new SMB2 Stack completely written by Apple (SAMBA is not used anymore). Apple's SMB2 implementation is not compatible with many other SMB2 NAS products on the market today while Windows 7, 8, and 8.1 work just fine. In short, it's an Apple bug.

As a workaround you can force OSX to use SMB1 instead of SMB2 using a configuration file:

  1. Open up the Terminal
  2. Paste the following line followed by a return key (command should be one single line)

    echo "[default]" >> ~/Library/Preferences/nsmb.conf; echo "smb_neg=smb1_only" >> ~/Library/Preferences/nsmb.conf

Explanation:

  1. A file called nsmb.conf is created in your home directory at the path ~/Library/Preferences/
  2. It adds the lines to force the use of SMB1 protocol instead of Apple's SMB2 (this is slower but more stable)
  • Thank you! Unfortunately I've already tried to do this, but the dialog you show on the screenshot asks for my REAL password. It doesn't accept anything else, and sharing still produces the same error :( – Aron Lorincz Dec 22 '13 at 10:49
  • @ÁronNemmondommegavezetéknevem I've updated my answer with another work-around you can try – Chrisii Dec 22 '13 at 19:22
1

If it's an option for you, you could possibly install SMBUP which replaces OS X's Samba (and it tries to be more or less compatible in the environment of Windows machines too). Of course, there are some caveats but when I had nearly the same issues with sharing Mac files over SMB it helped me out. Worked well in Leo - can't confirm if it works in Mavericks at all though.

SMBUp snapshot taken from donmorris.com/on/smb-and-mac-os-x-lion

Here are some more words on SMBUp:

1

Click more options. Select connect as another user from the Windows machine. Give your OSX login name. (The default is to use your Firstname Lastname) and the password, and it should work.

I just had this issue a a few minutes ago.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .