2

The problem started after forcing the mac to shutdown. Since then, when trying to boot, it stays stuck at the grey apple with spinning wheel. I've tried a few generic things to be able to access my data on my internal drive without success. I first tried booting on the restore partition from mountain lion, but the same apple with spinning wheel issue happens, which makes me think that it's the partition that's corrupted and not the Volume.

I've tried booting the iMac in Target mode and do the following:

1) I've tried using Disk Utility to repair the disk, but when trying to "Repair Disk" on the hardware item (not the volume one), the output gives:

Verifying and repairing partition map for “AAPL FireWire Target Media”
Checking prerequisites
Problems were encountered during repair of the partition map
Error: Some information was unavailable during an internal lookup

2) Data Rescue and Disk Warrior hang when I open them and when the Target disk is connected, but don't when I disconnect it.

What make me thing that some data can be saved is the following

3) Using single user mode, I can navigate through the different users’ folders, I can even open their text files. doing the fsck -fy command outputs: The Volume Macintosh HD appears to be OK.

When doing the /sbin/mount -uw / command, it outputs

SATA WARNING: Enable auto-activate failed
disk0s2: I/0 error.

followed by a few lines of gibberish followed by:

hfs: cat_delete() failed to delete thread record on volume Macintosh HD
hfs: Runtime corruption detected on Macintosh HD, fsck will be forced on     next mount
hfs_remove_orphans: failed to start transaction
hfs: hfc_btree_open: hfs_getnewvnode error 2

So I can’t mount the internal drive and I can’t seem to be able to mount an external drive to copy my files to it. It seems that there’s no network connection in single user mode (unless I’m missing something), so I don’t believe I can send the data through networking and my laptop refuses to mount the Target disk.

There are some important documents I would like to save and I was wondering if there was some way to access the files on the hard drive the same way single user mode does it?

Thanks a lot for any answers!

0

If you have some understanding of partition layouts, you could try using my disk editor iBored (http://apps.tempel.org/iBored/) to check the drive and its partition, search for the partitin start, then maybe copy just the partition data to a disk image file or to another disk's partition. All this can be done in iBored.

You could also try using iBored to erase the initial partition blocks (and save those blocks to a file first, so you could later restore them), to see if Data Rescue is then able to read the disk without hanging.

Also, you describe that in Single User mode, you tried to mount the (damaged) root disk as writable - that's not possible, clearly (since the volume is damaged). But have you tried to mount an external disk in writable mode? If that works, you could easily copy your files over then.

  • How do you mount an external drive without first creating a destination folder (in /Volume for example), therefore writing to the root drive? I'll take a look at your disk editor but I would prefer not to play in that kind of low level stuff :P – Sam Dec 22 '13 at 1:19
  • You can mount over ANY existing folder, so just mount the external drive to a folder that you do not need, e.g. the /tmp folder, or /Users/Guest/ or something like that. And you find the external drives (and their partitions) by using "diskutil list". If that doesn't like the ext drive, try "ls /dev/disk*", but then you better connect the same ext disk to a working Mac first to learn what partition contains what. Well, if you succeed to mount it you can look at it, too, so you can then tell if you mounted the right partition. – Thomas Tempelmann Dec 22 '13 at 1:24
  • The "overwriting /tmp" solution worked great! Thanks a lot, I was able to transfer all my files to an external drive. I didn't think that would be healthy to overwrite that folder... Thanks again! – Sam Dec 23 '13 at 0:59
  • That's great news. Glad I could help. Also, check out my find tool Find Any File, it might help you find files next time, sometimes better than Spotlight ;) – Thomas Tempelmann Dec 23 '13 at 9:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .