2

I have a problem that potentially causes me to miss important email: An incoming message is automatically marked as read after a few seconds. One can watch how a new email is at first unread in the inbox and then turns to read. This problem seems to occur only for one of several IMAP accounts.

My settings are: In the viewing tab a selection "Mark all messages as read when opening a conversation" check box is unset.

What could cause this? How can I diagnose if the problem is on the server side or if Mail.app is malfunctioning?

3
  • Did you get a solution to this issue? I'm facing the exact same problem
    – scanales
    Jul 23 '14 at 14:37
  • @scanales Yes, see my answer below. Really annoying problem.
    – clstaudt
    Jul 25 '14 at 8:42
  • did you find a solution to this? I am having the same problem on my iPhone. only with one IMAP account. I also have already unselected the box next to "mark all messages as read when opening a conversation" and can't find any other settings anywhere that seem to impact this. It is not my mail server as the account is working fine on my Laptop. I deleted the account and recreated it several times hoping it would resolve itself, but no luck. That was when I sent myself a test and realized that the Laptop was functioning correctly when the account did not exist on my iPhone so I am quite confiden
    – user199912
    Sep 4 '16 at 0:38
1

I've been able to fix the issue: In fact, it was the fault of OS X Server.

enter image description here

In the server app, under the calendar tab, there is a checkbox "activate invitations via e-mail". The problem disappeared when I unchecked it!

1
  • 1
    Oh, ok, I'm not running an OS X Server. I'll keep digging. Thank you.
    – scanales
    Jul 25 '14 at 18:51
0

Look at Preferences in the Mail.app

In the viewing tab there is a selection "Mark all messages as read when opening a conversation" make the check box unset.

1
  • It is already unset.
    – clstaudt
    Dec 21 '13 at 15:54
-2

Uncheck (Mail->Preferences->Viewing) 'Use classic layout'.

-2

When setting up your email account, make sure to choose POP3 instead of IMAP. It worked for me, and I had the exact same issue.

2
  • 2
    This is a very bad idea of you want to access your mail from multiple devices, as they're not synchronized with the server any more, but fetched from (and usually deleted afterwards).
    – Jens Erat
    Mar 8 '15 at 9:10
  • You can't actually do that unless your mail server supports both methods.
    – Tetsujin
    Mar 8 '15 at 9:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .