2

The calendar in my iPhone does not allow me to input new events. It was working fine, and I did nothing different to the Phone. When I try to input a new event, it won't 'stick'. Here's what I know:

  1. I can add an event directly into iCloud, and it will show up on iCal on my computer and in my iPhone.
  2. I can add event on my computer in iCal and it will show up on my iPhone, but not in my iCloud calendar.
  3. I try to add an event into the calendar on iPhone, and nothing shows up anywhere.

OSX 10.7.5
iPhone 7.0.4

  • Do you sync calendars with any cloud service? Check settings app and edit that into the question to avoid having this closed as a duplicate of the dozens of questions similar to this already asked. – bmike Dec 20 '13 at 19:42
1

You may be inadvertently saving the event to the wrong calendar. Often email accounts, such as Gmail automatically enable a calendar when being set up. If the event shows up only on your iPhone, and nowhere else, chances are your default calendar is set to something that you are not used to checking.

When you create an event, scroll down to where you can see the menu item "Calendar". Tap that, and choose one of your iCloud calendars. If the event then shows up on iCloud, and your computer, you have chosen the correct calendar.

If this is case, you will probably want to change your default calendar by opening your Settings.app, scrolling down and selecting "Mail, Contacts, and Calendar". At the bottom of this screen is a section titled "Calendars". Change the "Default Calendar" to reflect the one that worked correctly.

0

I had same problem. Then I saw that my mail, contact and calendars (under settings) had both iCloud and my Yahoo mail accounts having "Calendars", "Mail", "Contacts", "Notes". I deleted the calendars under my Yahoo Account but kept the calendars under iCloud and Wha-La...it was fixed.

0

Go into "Privacy" in "Settings". Select Calendars, and make sure there aren't any apps requesting access to your calendar. If there are any, turn them off! (This happened on my husband's phone, and as soon as I closed the app, the calendar was allowing new entries again.)

0

in the iCalendar app, go to the bottom and click "Calendars", in the center of the page under iCloud click on the calendar you want to view, usually it's "home", that brought up everything i wasn't able to see that i had previously added. good luck!

-1

I Cloud has to be activated. My calendar didn't have a + (exist) until I activated I Cloud.

  • 1
    What steps make up "activation" for iCloud? – bmike Aug 18 '14 at 23:51

You must log in to answer this question.

protected by Community Feb 23 '15 at 9:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .