3

I've tried to install Xcode 3.2 on my MacBook Pro with OS X 10.9, but during the installation (when it's almost finished) OS X had a kernel panic and keeps crashing immediately after login.

Kernel Panic picture

Xcode 3 is required to build Android 2.3 from the source code. How to fix it?

4 Answers 4

5

Why not just install the latest version of Xcode?

Xcode 3.2 was originally released all the way back in 2009 and since it's a very technical product by nature, it's not really a surprise that it crashes on a OS that was released 5 years later.

If you really, really need v. 3.2, I'd suggest looking into virtualization (Parallels Desktop or VMware Fusion are popular choices). You could then install Leopard (10.5) and Xcode 3.2 and compile via the virtual machine.

4
  • XCode 3 (exact 3.* version) is, unfortunatly, required to build Android 2.3 from the source code :( So, I think I really need VM.
    – artem
    Dec 20, 2013 at 15:49
  • @RankoR Yeah, I figured as much. Had to ask anyway, just to be sure :) I'd say a VM is the way to go. With the added bonus of being able to run other legacy (and current) OS's. Good luck!
    – Lasse
    Dec 20, 2013 at 15:54
  • Thanks :) But the primary problem for this moment is how to restore my OS without reinstalling it (I don't have backup of the whole system. All my data is backuped but I would like not to reinstall all the software one more time)? I've found the tutorial on SO, where the author says that CHUD remover can help, but how can I do it from recovery?
    – artem
    Dec 20, 2013 at 16:11
  • 1
    @RankoR: Don't think you can from recovery. But try booting into safe mode instead. You do that by holding down Shift when you hear the startup sound when booting. That might let you login and remove Xcode.
    – Lasse
    Dec 20, 2013 at 16:21
4

Xcode 3 shouldn't install on Mavericks, and if it does it definitely isn't supported by Apple.

To avoid the login crash try entering your login credentials, and immediately after pressing return, hold down the shift key to prevent anything from loading. IF that doesn't stop the kernel panic, then you will need to wipe, reinstall, and resort from your Time Machine backup.

The best bet for using Xcode 3 is to dedicate an old machine to running an OS that supports Xcode 3. From my notes it looks like that would Snow Leopard (10.6). Another alternative is, if your Mavericks machine is old enough to run 10.6, install that on a partition or a dedicated hard drive. I stopped working for a company this year that was still using Xcode 3 as the official compiler for release builds.

3

I agree with the other posts; installing down-level variants of Xcode on Mavericks is unfortunately a recipe for pain.

Better option than install a dedicated machine, why not run an OSX VM in Parallels / Fusion? At that point, to be honest you would be better off running a Linux VM and compiling from there - is there any reason why you can't do this?

3

I've solved this problem.

  1. Reboot to the recovery
  2. Mount system disk
  3. Open Terminal
  4. Go to /System/Library/Extensions/
  5. Remove every kext, containing "CHUD" in its name
  6. Remove AppleProfileFamily.kext
  7. Done.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .