33

I have two monitors on my Mac. I have just installed Maverick and I notice I can no longer stretch a window from the screen on my left to the screen on my right. Mac OSX Maverick 10.9 seems to pick one screen and it does not show the stretched window on the other screen anymore.

This is a problem because I like to use one particular program (VMWareFusion) to do my software development in full screen mode. No longer can I see my guest operating system in both screens anymore when I full screen it because of this problem... at least that is my hypothesis.

migrated from stackoverflow.com Dec 19 '13 at 20:16

This question came from our site for professional and enthusiast programmers.

  • While this OS feature/bug affects your development, this is a general feature/bug of the new version of the OS and you might have better luck at the Apple-dedicated StackExchange site. – Pascal Cuoq Oct 24 '13 at 19:46
  • Not that I think you will get an answer there. The feature/bug you are describing is documented in Mavericks reviews as one of the new feature/bugs of that version. There may be a setting for it, but probably not. arstechnica.com/apple/2013/10/os-x-10-9/11/#multiple-displays – Pascal Cuoq Oct 24 '13 at 19:56
58

I haven't tested it myself, but according to John Siracusa's review at ars, if you disable the "Displays have separate Spaces" checkbox in the Mission Control preference pane, the old behavior (including ability to split a window between displays) returns.

  • 15
    Works. Note that this requires logout/login to take effect. – MarcT Nov 1 '13 at 16:45
  • 2
    You lose the menubars at the top of non-primary windows, which is too bad. Also, one of my apps for window-snapping doesn't work anymore. If it wasn't re-login required it would be more convenient, because I don't want to stay in that mode just to get cross-edge window display. – Keith Tyler Sep 29 '16 at 16:27
  • 1
    Doesn't quite work on MBP OSX 10.13.3: if you stretch the app window too much it will still snap to one or another screen. :( – Todd Mar 28 '18 at 9:33
  • @Todd works for me in 10.13.4, I just made sure the app wasn't full-screen, then dragged one edge. – gib May 18 '18 at 10:47
2

I had this same issue and I just couldn't figure out what to do. After searching and searching, I finally found out what to do and I created a YouTube video showing the simple steps. Let me know if you this is the same issue you had.

https://www.youtube.com/watch?v=pnR98GOGtng

  • 3
    same solution as suggested above, but with a video. – ftrotter Aug 5 '17 at 4:59
1

Gordon is correct. You can get the old mode back in Mission Control, but it requires a re-boot. I too use my monitors in a similar fashion you describe. Having the menu bar and dock on the second monitor is great, but not the trade-off. Hopefully a third party will c

  • 7
    This answer should have been a comment on that answer, not a separate answer. – agweber Oct 28 '13 at 20:34
1

If you would like the best of both worlds you could use the third party application called SecondBar: https://www.macupdate.com/app/mac/33264/secondbar after changing the "Displays have separate Spaces" checkbox in the Mission Control preference pane

0

Gordon is correct (I tested it because I am not happy about the new behavior), but doing so disables some of the new features, such as having the correct menu bar on both screens. So you don't seem to be able to have the best of both worlds. Also, minor correction to user1887686, you don't need to reboot, you just have to logout and log back in.

  • 3
    This answer should have been a comment on that answer, not a separate answer. – Gustavo Bezerra Apr 3 '16 at 3:19

You must log in to answer this question.