9

When I turn on the personal hotspot, I cannot get a DHCP network address on my computer. I've tried with 2 different computers and an Android phone. They can connect to the network router but not my iPhone, which won't give out an IP address.

image

It just says "the connection is limited" and I get a 169.* address on my computer.

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix  . :
Link-local IPv6 Address . . . . . : fe80::5c88:c538:f588:efe%4
Autoconfiguration IPv4 Address. . : 169.254.14.254
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

When I connect via USB cable, it does not work either:

imgur

After I reset network settings (Settings > General > Reset > Reset Network Settings), I was able to briefly get an IP address, but I was not able to ping any servers, like Google's public DNS server. I received a phone call while the hot spot was turned on, and I believe that is what allowed me to get an IP address, but I'm not sure why. Subsequent disable/enable cycles failed to get an IP address.

$ ipconfig
Windows IP Configuration
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::5c88:c538:f588:efe%4
   IPv4 Address. . . . . . . . . . . : 172.20.10.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.240
   Default Gateway . . . . . . . . . : 172.20.10.1

$ ping 8.8.8.8
Pinging 8.8.8.8 with 32 bytes of data:
Request timed out.

I even tried to connect via Bluetooth, but that didn't work either.

$ ipconfig    
Windows IP Configuration
Ethernet adapter Bluetooth Network Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::b09b:4eb7:6091:ac17%5
   Autoconfiguration IPv4 Address. . : 169.254.172.23
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

I have an unlocked iPhone 5 with latest iOS on MetroPCS.

Reference

http://support.apple.com/kb/TS2756. I have not restored/reset the entire phone. Would rather not have to.

  • Two ways to narrow this down. 1. Connect other devices (android, iOS, computer) to the hotspot to see if it's not handing out DHCP properly. 2. Debug your computer(s) to make sure no firewall is blocking DHCP and or other network configuration issues. That would need more details since there's not a log on iOS that shows easily what's happening with hotspot operation. – bmike Dec 19 '13 at 18:52
  • 1. I already mentioned I tried connecting two different computers to the phone. 2. There is no firewall on the wireless network. Plus I can connect to the wireless router. – Chloe Dec 19 '13 at 18:59
  • Hope you have already done the restart phone basic step. If yes, try creating hotspot again. – iDev Dec 19 '13 at 19:10
  • @Chloe I know, but you still need to keep changing one thing until you arrive at a workable setup. – bmike Dec 19 '13 at 19:59
  • @iDev Yes I've tried over several weeks and I've reset the phone several times between that time, mainly because the Siri keyboard microphone key was grayed out. – Chloe Dec 19 '13 at 21:54
5

This one drove me nuts but I believe this will work for most of you:

Basically the APN settings for the Hotspot were missing.

If you can browse the internet on your phone and you can activate your Hotspot but you get the yellow exclamation mark on the computer's wifi or the 'Network cable unplugged" with USB tethering, try the following:

  1. Open Settings -> Mobile Data -> Mobile Data Network
  2. Check the APN/Username/Password settings under "Mobile Data" (most of the time username and password - if used - are identical, if not search APN settings on your provider's homepage)
  3. Enter the same settings under "Personal Hotspot" further down on the same settings page
  4. Return to Settings Menu
  5. Switch Mobile Hotspot off and on
  6. Connect to your Hotspot -> Internet on your computer should be working now

The problem appeared for me while roaming/after changing sims, basically every time the network settings get reconfigured and the APN settings automatically change for the roaming network/new network.

Hope it works for you too!

3

Found it! I went to a MetroPCS store and they looked at the phone. They enabled hotspot for my account, but it still would not help. They gave me a phone number to call, I called tech support, and was told:

  • Turn off LTE. Settings > Cellular > Enable LTE (Off)
  • Turn off/on Personal Hotspot.

Now it works! It only works on 4G.

I don't know if having the hotspot feature ($5/m) enabled on your account is relevant or not. I thought all data was combined, and since it is an unlocked phone, how could they know?

  • It turns out having the $5/m hotspot feature is unnecessary. It works with LTE with version 10.2 of iOS now. I just tested it. There must have been a bug in iOS. – Chloe Dec 20 '16 at 16:27
  • This worked for me too, my iOS 10.3 or provider won't allow LTE tethering via USB but works through WI-Fi... – malix Feb 8 '17 at 17:05
  • I intermittently got "Failed to get IP address" when trying to hotspot my Samsung mobile to my iPad. Turning off the LTE network on my iPad and using 4G /3G fixed the problem for me. Finally!!! Thanks for the tip above ... I had tried static IP addresses and fiddling with the APN to no avail. Turns out whenever I had really good signal (LTE) hotspotting wouldn't work ... the times I was only picking up 3G it worked. Now I know how to get it to work whenever I want ... 👍👍 – Natasha Oct 31 '18 at 21:44
2

i had the same problem earlier on and it was soo frustrating!

Anyway i got it fixed (posting here using my revived laptop!) and the following was what worked for me:

Start > Control Panel > Windows Firewall > Allow a program or feature > remove Bonjour > reboot computer and watch the magic unfold.

P.S This was a solution posted by kind humans in another forum but it took me long to find it..Just thought i could share it on this forum as well to hopefully make the search easier for others.

cheers, hope this would solve your problem too! :)

  • 1
    That doesn't explain why the Android phone would not get an IP address from the iPhone. Android doesn't run Bonjour. – Chloe Dec 20 '16 at 16:23
1

I am going to take some time to do a summary of networking and troubleshooting to try to help you out.

When your phone is running a Personal Hotspot it starts up a couple services on the phone's OS one being a DHCP service. DHCP might seem familiar two you because it is what is the part of every network that gives out the IP address.

A network has two sides to it, internal and external. In our modern day there are external IPs that look like this 2001:0db8:85a3:0042:1000:8a2e:0370:7334 and internal IPs that look like this: 127.0.0.1 or maybe you have seen 192.168.1.1

If you see a IP address on your computer(s) with 169.... this usually means that the DHCP service is not reachable. This could have several reasons and in this case I am going to assume that your Windows computer does not have the correct driver to speak with the iPhone's DHCP service. If you connect your iPhone via USB the driver is different than Bluetooth or WiFi.

We should be able to assume that the iPhone's network is fine if you can surf the web on your iPhone. Now getting that network over to your Windows computer is a matter of connecting the iPhone via USB (or WiFi or Bluetooth) and making sure that the driver is installed correctly. This should be the case as long as you have the latest version of iTunes installed on the computer and the iPhone shows up in iTunes as an available device.

The error message you get of "Connection in limited" is to my understanding the Windows version of "self-assigned IP address" which results from the computer not understanding the DHCP and/or DNS settings from the device it is getting network activity from.

Please verify all of these things and if you notice anything else out of the ordinary and I'll update my guide to help more.

  • I showed in the question that I already tried USB and Bluetooth PAN, and that I tried on multiple computers (different Windows versions) plus Android. – Chloe Jan 10 '14 at 18:00
  • I wasn't just trying to tell you how to fix it but to give you clues and the process that is usually invisible. On the other computers, was the latest iTunes installed? On the other hand your question is "How do I troubleshoot..." and that is what I am trying to answer. Seeing as how I spent just as much time writing my responses as you did yours I would appreciate a bit more cooperation – Andrew U. Jan 13 '14 at 14:02
  • @Chloe with all the troubles we have gone through to try to help you out, it might be time to restore the phone. But the last thing that comes to my mind is double checking with your provider that your contract supports Personal Hotspot – Andrew U. Jan 13 '14 at 14:02
  • That's my next step: take phone & laptop to MetroPCS store and make them fix it. – Chloe Jan 13 '14 at 14:44
  • That's not my suggestion but that will hopefully get a resolution. Best of luck, we are here for you if you still have troubles – Andrew U. Jan 13 '14 at 14:45
1

I had this same issue. Turns out that when traveling to another country and using a SIM card, I was required to enable a profile on my iPhone. This profile set the APN, which in turn was blocking me from tethering. To check on your iPhone, this go to:

Settings app → Cellular → Cellular Data Options → Cellular Data Network

In my case, the APN was pointed at the network in the country I had used the SIM card in. Even with this APN I was still able to use my phone on my current network with little troubles, but I was not able to tether.

If you see that the APN settings are wrong, and resetting them does not work (my profile prevented them from being reset), go to:

Settings app → General → Profile (if this does not exist, then you don't have any profiles installed). Delete the profile you do not need and this may solve your problem.

0

I tried everything above, but did not fix the problem, I made the pc "discoverable" on my private network, then the dropped gateway problem went away. Do this:

  1. Open Settings.

    The Settings window appears.
    
  2. Click Network & Internet.

    Your network and Internet related settings are shown.
    
  3. In the panel on the left, click either Wi-Fi (if you’re connected to a wireless network) or Ethernet (if you’re connected to a network using a network cable).

    A window with settings for your network appears.
    
  4. Find the Related setting section on the right, then click Change Advanced Sharing Settings.

    The Advanced Sharing Settings window appears. 
    
  5. Expand the network profile currently assigned to your network connection.

    It is marked with the words “current profile” on the right side of its name.
    
  6. In the Network discover section, select “Turn on network discovery”. Also, check the box that says “Turn on automatic setup of network connected devices.”

    Turning on network discovery.
    
  7. Click Save changes.

  8. Close the Settings window

You must log in to answer this question.

protected by Community Oct 31 '18 at 23:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .