1

I need dnsmasq to run at boot on Mavericks. I've got dnsmasq working fine. I've created a .plist file in /Library/LaunchDaemons with the following contents:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>uk.org.thekelleys.dnsmasq</string>
    <key>ProgramArguments</key>
    <array>
            <string>/usr/local/sbin/dnsmasq</string>
            <string>--keep-in-foreground</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
</dict>
</plist>

This runs perfectly if I do:

sudo launchctl load -w /Library/LaunchDaemons/uk.org.thekelleys.dnsmasq.plist

However, it does not start at boot. Permissions are: -rw-r-xr-x What am I missing?

7
  • what permissions are set for uk.org.thekelleys.dnsmasq.plist? – l'L'l Dec 19 '13 at 18:28
  • Not sure if you are following this but it might help... apple.stackexchange.com/questions/13691/… – bmike Dec 19 '13 at 18:39
  • @I'L'I: Edited question to include permissions info. – Sheetzam Dec 19 '13 at 19:39
  • Permissions should be -rw-r--r-- (no execute) but I don't think the x will prevent it from starting. One thing I'd try is to remove the --keep-in-foreground option. On boot, any process that tries to access the window server won't run until someone logs in. Also, check /var/log/system.log and see if there are any messages. It might give some information about what's failing. – Justin Mrkva Dec 19 '13 at 22:34
  • Not an answer, but I'm sure LaunchControl will tell you why. – LCC Dec 20 '13 at 8:40
0

Thanks to LCC for pointing out LaunchControl. It indicated the ownership of /Library/LaunchDaemons was incorrect.

The solution to this problem was to be sure /Library/LaunchDaemons had ownership root:admin, and permissions for the directory were rwxr-xr-x

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .