3

Since I updated my OSX to version 10.9.1 I am unable to open text files from the Finder.

I always opened the files with the default TextEditor. I've tried to change the default application from TextEditor to Sublime Text 2, which results in exactly the same error:

"Unable to find the application"

When I open TextEditor or Sublime Text 2 I can successfully open the file and view it's contents.

Is there a way to fix this problem?

  • 1
    You could try resetting the Launch Services database by running $(locate lsregister) -kill -domain local -domain system -domain user. – Lri Dec 19 '13 at 15:55
2

Try setting the default app to open .txt files using Get Info

  1. Left click a text file
  2. Choose "Get Info"
  3. Under "Open with:" choose the app you want to use as the default
  4. Click "Change All..."
  5. Click "Continue"
  • I tried this without success the first time. After a reboot I tried the suggested solution again, now it works. Weird stuff :) – MysticEarth Dec 23 '13 at 9:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .