3

Somehow, the word procede has made its way into my OS X system as a correctly spelled word. If I type it in Text Edit, BBEdit, or Mail, the spell checker will not mark it with red underlines.

enter image description here

How can I fix this? That is, how can I have my system correctly flag this word as incorrect spelled? The word does not appear in my

~/Library/Spelling/LocalDictionary

file. My system has no files in

/Library/Spelling

I've stared at the spelling and grammar options in multiple applications and don't see any obvious ways to tell the system to remove a word from the dictionary.

enter image description here

4

Whilst many words are in ~/Library/Spelling/LocalDictionary, there's also words contained in the localisation that you are currently in, such as en or en_GB.

Try looking in such files for the word. You can find which file it's in using the following Terminal command:

grep -lr "procede" ~/Library/Spelling/
  • 1
    +1 for good information, but it doesn't solve my specific problem. Also — it seems like there should be a UI for this. – Alan Storm Dec 18 '13 at 21:20
2

Open up TextEdit. If not presented with an “Open…” dialog, select “Open File…” from the “File” menu or press ⌘O (an oh, not a zero). Press ⇧⌘G then copy ~/Library/Spelling/LocalDictionary and paste that text into the location panel; click "Go" or press enter, then press enter again or click "Open". You should be presented with a series of “learned words”, one per line.

Edit to your satisfaction. I took an opportunity to add many of my project names; all odd-looking nouns like cinje and korcu… When done, save the file if needed, and close.

Open up your Terminal.app. (Via Spotlight is easiest, or you'll find it in /Applications/Utilities via Finder.) Enter the following and press return:

ps x | grep Spell

You should see something similar to the following on your screen, don't worry if yours is missing the grep line:

53535   ??  S      0:02.68 /System/Library/Services/AppleSpell.service/Contents/MacOS/AppleSpell
70766 s002  R+     0:00.00 grep --colour Spell

The first number on the line containing the reference to AppleSpell.service from your own output you'll need to remember for the next command:

kill -HUP 53535

Replacing 53535 with your own number. This instructs the "spelling service" to "hang up" and reload its configuration and data files, making the changes you made to the data file effective.

0

I'm still not sure what the ultimate reason for this is, but I was able to fix this problem by going to

Edit -> Spelling -> Show Spelling Panel

and changing the selected dictionary from Automatic By Language to U.S. English.

  • Intriguing; there must be a locale difference, I do not have a "Show Spelling Panel" option. – amcgregor May 28 at 23:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .