3

Disk Utility report (Consistent with Finder)

Mount Point :   /Volumes/partition2
Format :    Mac OS Extended (Journaled)
Owners Enabled :    No  
** Number of Folders :  10

Capacity :  1.9 TB (1,900,231,068,160 Bytes)    
Available : 1.9 TB (1,899,390,058,496 Bytes)
** Used :   841 MB (841,007,104 Bytes)**
** Number of Files :    55

sudo zsh;

du -hs *(D)

744K    .Spotlight-V100
0B  .Trashes
4.0K    .fseventsd

I am unable to recover those 841 MB. I have tried reformatting but nothing changes.

I noticed this issue after copying 2 files to the external drive and deleting them. I didn't pay attention to those stats before doing that but I suspect they were the responsible what's happening. Their summed sizes were at least similar to these 800 MB (I can't confirm if it's exactly the same as they were since deleted).

It's a new external hard drive and I need to know whether it's working properly. I have no experience with those and I don't know if I'm simply missing something obvious.

UPDATE 1: Trying the 1 pass zeros erase in Disk Utility (as suggested by @IconDaemon)

UPDATE 2: After the 14 hour process, there are still 841MB used. I can live with that but I fear this may accumulate.

UPDATE 3: Repair Disk

Verify and Repair volume “partition2”
Starting repair tool: 
Checking file system
Checking Journaled HFS Plus volume.
Checking extents overflow file.
Checking catalog file.
Checking multi-linked files.
Checking catalog hierarchy.
Checking extended attributes file.
Checking volume bitmap.
Checking volume information.
The volume partiton2 appears to be OK.

It didn't solve the problem.

UPDATE 4: I ran the WD Drive Utilities' Complete Drive Test and no bad sectors.

UPDATE 5: Reformatted to FAT - 2.2MB Used. Then tried Exfat - 9MB Used. HFS+ again - 850 MB.

Maybe it's just the case that HSF+ needs 0.05% of the drive to work as @IconDaemon pointed out. Alternatively Disk Utility is using some inefficient process to do the formatting.

  • What happens if you try to empty the trash - while the external drive is connected? I found that was the easiest way recover space on mine. – user65154 Dec 18 '13 at 12:05
  • The trash is already empty. I reformatted the drive trying to fix it and haven't copied anything to it since then. – user282662 Dec 18 '13 at 12:13
  • Which invisible directories (folders) are you referring to here? .fseventsd and .Spotlight-V100 don't seem to use 800MB. – nohillside Dec 19 '13 at 8:26
  • I guess I should have made it clearer. Disk Utility says there should be 10 folders and 55 files but terminal reports only 8 folders and 53 files. 2 missing folders and 2 missing files. – user282662 Dec 19 '13 at 11:40
  • For the missing directories, I think they're possibly "." and "..". For the missing files, I was using the wrong qualifiers **/*(D.) - the correct would be **/*(D^/), I guess, but that also gives 53 matches. I'm probably making things more confusing. – user282662 Dec 19 '13 at 12:09
0

If you use the Security Options in Disk Utility and write at least one pass with zeros, that should truly delete whatever real files that are there. A disk must always use a small portion of its capacity for indexes and directory structures, but 861MB seems a bit large for that. Perhaps the drive controller has mapped out a slew of bad blocks, reducing the capacity, which could be an indication of a bum drive.

  • This won't change the size allocated to whatever files there are on the HD. – nohillside Dec 19 '13 at 7:04
  • It's probably indexes and directory structures. – user282662 Dec 20 '13 at 12:21
2

Try using Repair Disk in Disk Utility to fix any disk anomalies, or run fsck -fy / in single user mode.

  • Tried that. Both "verify disk" and "repair disk" say the volume appears to be OK. – user282662 Dec 19 '13 at 6:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .