6

I already downloaded (and installed !) the latest file from ASIX.com, which is the latest to this day, but System Information does not list the port as being available when I connect the USB 3 Hub directly to the USB 3 port of my MBP.

Mike Ohlsen wrote here that when plugging the hub into another USB Hub, and not directly into his Mac, then OS X does detect the ethernet interface and displays the device in the System Information.

I can confirm this. But this is not useful in the long run since this defeats the whole idea of having a SuperSpeed Hub in the first place !

Leif's solution doesn't work in 10.9. That is :

sudo kextunload -b com.asix.driver.ax88179_178a
sudo kextload -b com.asix.driver.ax88179_178a

as I get this reply in Terminal :

com.asix.driver.ax88179_178a failed to load - (libkern/kext) not found; check the system/kernel logs for errors or try kextutil(8).

And anyway it would be a terrible hassle to have to do this each and every time.

But when my "USB 3 Hub with Ethernet" is connected through a USB 2 Hub, then the kext is loaded (inexplicably for me) :

MBP-computer:~ username$ kextstat -l | grep asix
  137    0 0xffffff7f82879000 0x8000     0x8000     com.asix.driver.ax88179-178a (1.0.0) <36 34 7 5 4 3 1>

In case you wonder : enter image description here

Hence my question :

How can I force Mac OS X 10.9 to see the ethernet port of my hub (Asix AX88179) ?

  • Since we see that Mac OS X 10.9 can see the port when the hub is connected through another hub
  • Since that port indeed works in this configuration, showing that the port is functional (the hardware is effectively working, so is the driver)
  • I have a similar problem. I normally connect my Asix AX88179 via a USB 3.0 hub to my MacBook Air but it is very unstable. After reading your post, I tried to connect the dongle directly to my Mac and it won't see it. Point is don't bother connecting via a hub as it quickly disconnects. Worse, although the network is simply not available, the setting still show green status. – marcoseu Dec 20 '13 at 15:50
2

After I posted my comment, I contacted support of my product (ianker.com) and after few email exchange they sent me a replacement dongle claiming that I had a defective unit.

I was skeptical but the replacement actually worked! MacOSX immediately recognised it when I plugged it in directly into the Mac.

  • Sorry, my fault. Thought you were the OP. – Max Ried Mar 20 '14 at 17:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .