When switching back and forth between full-screen mode for YouTube videos in MacOX Mavericks, I find the zoom effect very annoying and jerky. Is there a way to turn this off, so such videos can just snap in and out of full-screen without animation?


chrome://flags/#enable-simplified-fullscreen; Enable it and restart chrome

  • 1
    That useful option has been removed now unfortunately. Version 39.0.2171.27 beta (64-bit) – cavalcade Oct 19 '14 at 7:19

After months of research this is how to disable the annoying animation that occurs on some videos on Youtube.

Delete the file called ffmpegsumo.so in: /Applications/Google Chrome.app/Contents/Versions/[your current version]/Google Chrome Framework.framework/Libaries.

And voilà! Enjoy!

  • I would recommend renaming instead of deleting (in case it breaks something else). – nohillside Mar 29 '14 at 16:37
  • i deleted it and been using chrome for two weeks now. Everything seems fine so far – jeriko Mar 30 '14 at 1:50
  • 1
    That file no longer exists in Chrome (Version 77.0.3865.120 (Official Build) (64-bit)) – drkvogel Oct 15 '19 at 12:36
  • any other work arounds? – azz0r Feb 5 at 12:59

I Have finally found the answer to this question after several month of painful slow fullscreen animations. The problem is that I don't know exactly how I did because now that it has switched back to normal, i can't do it again. When you read your youtube video on chrome, you need to right click then go to HTML5 option or something of the sort the click "disable HTML5 and switch back to regular". The button was green for me, I tried it and all my problems were finally resolved. If someone can try and explain it better than me. Hope that will help.


Yes, you can use Safari, there are no annoying effects while switching)

  • 5
    "Yes, you can use Windows" is as valid a response. – Joseph Lennox Dec 25 '13 at 19:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .