26

On OS X 10.9 (but no prior version), every now and then, I start getting strange network errors. I can still ping, but anything that requires actual content (like a web page) completely stops.

For example:

$ ping 80.68.93.197
PING 80.68.93.197 (80.68.93.197): 56 data bytes
64 bytes from 80.68.93.197: icmp_seq=0 ttl=46 time=175.291 ms
64 bytes from 80.68.93.197: icmp_seq=1 ttl=46 time=172.519 ms
^C
--- 80.68.93.197 ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 172.519/173.905/175.291/1.386 ms
$ curl http://dailyjs.com/
curl: (7) Failed to connect to 80.68.93.197: Can't assign requested address

It seems similar to this message thread, but I don't see an answer there.

I've tried deleting the ethernet interface and re-adding it, but that doesn't seem to help.

I've tried deleting the ethernet interface and turning on wifi, which shows the same symptoms.

A reboot might fix the problem, but it's rather intrusive. Any ideas?

  • Seems like a bug in OSX network stack. Also another message thread at discussions.apple.com/thread/5551686?tstart=0 – hanxue Feb 20 '14 at 9:54
  • 1
    Check whether your VPN software is leaving behind static routes to the tun/tap device: netstat -n -r If that is the case make sure you configure it to reset the primary interface after disconnecting. – user86213 Jul 29 '14 at 3:22
31

In my case there was only one host giving me this issue. sudo route delete example.com fixed it instantly, no reboot.

  • What is causing that problem? – Whitecat May 25 '17 at 17:17
  • I had this problem too on my Mac; this fixed it for me. Other connections were working fine, but the target hostname had been updated to point to a different server, and I was getting the OPs error. route flush and other stuff didn't work, but this did. – Doktor J Jan 19 '18 at 20:24
7

A reboot was the only thing that corrected the problem for me. :(

  • Just a note; I'm currently running OS X 10.11 (.2 Beta) and I no longer have this problem. I strongly suspect it was due to the DNS changes in 10.9 which Apple rolled back in 10.11. So, if anyone is still experiencing these outages, upgrade to the latest version of OS X and that should fix it. – Richard Hurt Dec 2 '15 at 16:32
2

I just fixed this from the command line on my own workstation running OS X 10.11.6 by flushing the routing table, and then adding my default route back in:

    sudo route -n flush
    sudo route add default 192.168.1.1
  • This was the only way I could get my Sierra install back on the rails. – w00t Feb 6 '17 at 12:56
0

I saw lots of TCP sessions in CLOSED, FIN_WAIT_1, and several other states, and they were not clearing. It looks like the TCP timer just stopped. I had to reboot to get my network back.

0

I saw this problem rear its head when NFS automounts started failing. They attempted to fall back to UDP. Running mount_nfs -o tcp fileserver:/export/path /mnt/path reliably failed with:

mount_nfs: can't mount /export/path from fileserver onto /mnt/path: Can't assign requested address

kernel.log contains entries like this as well:

Mar 31 15:40:38 guru kernel[0]: 0xfbdf4000, 0xe00002be Intel82574L::outputStart - NoResources from txFrame - pkt saved

OSX - 10.9

A reboot also cleared the problem.

  • Also, other network connections worked fine (eg: from a browser) Maybe this is a port allocation issue since NFS uses trusted ports. – imoverclocked Mar 31 '14 at 22:54
0

I cured one by unplugging my USB WiFi interface and plugging it back in.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .