I am using multiple desktops on my Mac. Depending on how I use them, the desktops seem to switch around. For instance the place where 'Terminal' is (second from the left) moves one to the right. Where 'Terminal' used to be is now 'Desktop1'. The screenshots below hopefully clarifies what I mean. How can I keep them static at the same location?enter image description hereenter image description here

1 Answer 1


Go to System Preferences → Mission Control and uncheck Automatically rearrange spaces based on most recent use.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .