5

I am using Magic Mouse with my iMac having OS X Mavericks 10.9.

Everything was working fine since today morning, I realized that my Magic Mouse is only responding to scrolling and primary, secondary click. All other gestures of Magic Mouse were not working.

And another issue which I don't know it is related or not is that Google Chrome does not scroll. Restarting Chrome fixes problem for 2-5 minutes but not permanently.

I use all gestures frequently for spaces, zooming, swapping, navigating, etc and I am having very difficulty without these features.

Things I have tried:

  1. Checking/Resetting Magic Mouse settings from system preferences
  2. Turn Magic Mouse on and off
  3. Disconnect/Connect Magic Mouse
  4. Restart iMac, press power button and "command+shift+p+r" and from troubleshoot screen, verify/repair Disk Utility (OS Disk)
  5. Connect mouse with other iMac (mouse is fine)

After all these things, problem still exists. I have searched it in Google and I have found out that many people have received this problem but I couldn't find any solution.

Does anyone here know about this issue and have some solution??

1

I solved the same problem by going to mouse in preference and unblocking the gesture the second and third gesture leaving only the "Swipe between pages" enabled.

-1

had the same issue and called apple.

Reset your PRAM. Fixed the issue for me. Google for how to reset PRAM.

  • What makes for a good answer is when you provide the instructions on how do the procedure you recommended so readers don't have to go look up outside Ask Different. - It's no longer called PRAM, by the way; it's NVRAM – Allan Jun 16 '16 at 15:55
-3

Disable the gesture and the re enable it again...

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .