3

OSX mavericks added support for having the menu bar available in multidisplay mode, which is nice, but now whenever I try to watch a movie in fullscreen on the other display it seemingly leaves a solid grey bar at the top of the screen which is very annoying. Has anyone had this experience and does anyone know how to get rid of it.

  • Which Software are you using to play a Video? I would recommend trying an alternative Videoplayer in order to check if that is a OS Problem or a Videoplayer Problem/Feature/Bug. – J.C. Dec 24 '13 at 8:11
  • Are you using VLC? Just exiting and then entering full-screen mode removes the grey lines for me. If that doesn't work, maybe you can try toggling which full-screen mode VLC uses (native vs. VLC's old full-screen mode) by going in Preferences > Interface > Use native fullscreen mode. – Marko Nikolovski Dec 24 '13 at 8:20
  • @MarkoNikolovski your comment is good but then I can't use the menu bar in fullscreen mode – aaronman Dec 24 '13 at 19:25
  • @aaronman Why not? I can definitely access it if I'm in VLC, but that's true for most apps in full screen mode. – Marko Nikolovski Dec 26 '13 at 8:44
  • You could always disable the multi-menubar: system pref > mission control > and uncheck "displays have separate spaces" – y3sh Dec 29 '13 at 16:45
2
+50

There's a solution that I've found which should solve this issue with any application that you encounter this with.

  1. Download the free application Nocturne
  2. Install, launch, and click the icon in the menubar
  3. Select Preferences > then check Dim when inactive
  4. Adjust the slider all the way down when desired
  5. Enjoy! :)

Nocturne saves the day!

I've been using this application for ages, and without a doubt it's one of my favorites.

  • What exactly will this do? – aaronman Dec 24 '13 at 19:27
  • @aaronman, it should hide the gray bar you're not liking. The bar in question appears to be the menu bar actually, so this should allow you to 'dim' it completely so it's not visible as before. – l'L'l Dec 24 '13 at 22:03
  • can I still use the menu bar on both screens though? – aaronman Dec 29 '13 at 21:21
  • @aaronman * It may or may not work — it all depends on what displays you have, etc. It works on mine without issues, although a friend had to use a different one called MenuShade for whatever reason. The main idea here is that you're wanting to dim the menu bar or hide it as needed to alleviate the problem until Apple fixes the issue (when and if they do); whatever app gets the job done is secondary to what my answer is suggesting. – l'L'l Dec 30 '13 at 4:33
1

Yes, I have experience with this. Mostly in non-Apple browsers (Chrome). The comments help with stand-alone video players but if you're using a browser in combination with a plugin like Flash or Silverlight, it seems that the browser doesn't take multi-menu bars into account and thus a menu bar size grey/black bar is left at the top.

If you on the other hand use Safari with these same plugins, you'll get "full" fullscreen.

Currently I only watch fullscreen Netflix via Safari.

I believe it's up to the developers of the specific application to fix this issue. Until then, you'll have to use specific applications, or, as the comments suggest, change the fullscreen mode in VLC.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .