0

I recently had to restore my iPhone 4S (iOS 7) and when I turned it back on and the activation screen came up, it prompted me for my Apple ID credentials. I put in my Apple ID username and password but it says that it's wrong. I tried to change my password, but when I did, and tried the new password, it still doesn't work.

What should I do?

I obviously can't even use my phone to make a call.

1
  • I'm assuming that you have confirmed, positively, that the exact same login info works on other devices, or appleid.apple.com, as you are using for this. Also, do you have a good wifi, or cellular data connection? Commented Dec 14, 2013 at 16:36

1 Answer 1

1

Try connecting via https://appleid.apple.com/ probably something wrong with your password.

Consider once you have access to the page to check your contact information, add a secondary e-mail etc…

If you still experience problems you should contact an Apple adviser via http://support.apple.com/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .