I have an external hard drive (Verbatim #47576) setup as a Time Machine drive.

Everyday, at random intervals, the computer warns me that the disk was not ejected properly. Why? How to prevent that? Is there a real problem?

iMac8,1 , MacOS X 10.6.7, Darwin 10.7.0,


This happens because of a USB Sleep issue with some external usb devices. This happens when the USB disk is put on sleep.

Some people claim that this problem is solved by disabling Put the hard disk(s) to sleep when possible in the Energy Saver preferences pane.

  • I wonder, is there some way to only disable the external drive from sleeping? – Michael Nov 24 '14 at 20:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .