I am running Mac 10.8.5 on a 2008 MacBook Pro, I have my time machine save to an external hard drive. Recently I have been unable to back up my machine because it gets hung up on 'Preparing Back Up' I have seen it chug away for 5 hours preparing that thing, I'm begging to think that it might be broken. I have gone into the external hard drive, and deleted the .inProgress then tried to Back up, didn't work. I have also tried to delete the old back ups, I say tried because while the delete dialogue comes up, they don't go anywhere. I have had to do this in standard finder view because the Starfield freezes when I try to go into that. So my questions are these, what is wrong with my Time Machine? Can it be fixed? Should I just reformat my external hard drive and restart the Time machine?

EDIT: The logs for the inProgress files were empty, there is no latest and the last one that worked, from october said:

Time elapsed: 0.144 seconds

Processing preflight info
  Space needed for this backup: 3.54 GB (864605 blocks of size 4096)
  Preserving last snapshot /Volumes/TR/Backups.backupdb/Danny Michaelis’s MacBook Pro (2)/2013-10-13-174902.inProgress/6949$
Finished processing preflight info

Copying items from "Macintosh HD" (mount: '/' fsUUID:A336210F-DE80-3901-A8E1-2146BBCC66F6 eventDBUUID:5D8F456A-237A-477B-B3EC-D$

Error: (-36) SrcErr:NO Copying /Users/lego90511/.appinventor to /Volumes/TR/Backups.backupdb/Danny Michaelis’s MacBook Pro (2)/20$
Error: (-36) SrcErr:NO Copying /Users/lego90511/.DownloadManager to /Volumes/TR/Backups.backupdb/Danny Michaelis’s MacBook Pro (2$
Error: (-36) SrcErr:NO Copying /Users/lego90511/Applications/Portal.app to /Volumes/TR/Backups.backupdb/Danny Michaelis’s MacBook$

Finished copying items for "Macintosh HD" (mount: '/' fsUUID:A336210F-DE80-3901-A8E1-2146BBCC66F6 eventDBUUID: 5D8F456A-237A-477$

Time elapsed: 29 minutes, 10.000 seconds
Copied 3092 items (25.7 MB)
Gathering events since 3981278.
Needs new backup due to change in /usr/discreet/backburner/Network/Servers/0022412EF7D001C6.xml
Some filesystem changes made during the course of the backup may not be accounted for. Still busy after 2 retries.

Backup complete. Total time elapsed: 33 minutes, 4.000 seconds

EDIT: Result when trying to manually delete the .inProgress files.

/Volumes/TR/Backups.backupdb/Danny Michaelis’s MacBook Pro (2) 🍔 sudo rm -rf 2013-12-10-105000.inProgress
rm: 2013-12-10-105000.inProgress/5ADB13D8-B389-41FB-8D03-68664417956E: Operation not permitted
rm: 2013-12-10-105000.inProgress/96A0E2FF-58AC-4E37-8ACA-AA2E8CA64BB7: Operation not permitted
rm: 2013-12-10-105000.inProgress/A77B6AC7-B833-49E2-BA5D-539310D7EFBD: Operation not permitted
rm: 2013-12-10-105000.inProgress/C1D640A9-FC6D-4EF4-A7A1-5436F26B445A: Operation not permitted
rm: 2013-12-10-105000.inProgress/C5CC4A02-9D03-4338-A415-EABA563B7E60: Operation not permitted
rm: 2013-12-10-105000.inProgress/CB5011C8-4C67-42A9-9BE7-0BC8A07C0031: Operation not permitted
rm: 2013-12-10-105000.inProgress/E52CEACD-A8EC-4E8A-B461-7EE00CD4D9AC: Operation not permitted
rm: 2013-12-10-105000.inProgress/E57AD845-3A4F-4625-830A-017D8C02CA42: Operation not permitted
rm: 2013-12-10-105000.inProgress: Operation not permitted
  • Please use code formatting for Terminal output — a single endless line is extremely difficult to read! I've edited your post in an attempt to add code formatting, but if I've not edited it correctly please re-edit.
    – grg
    Dec 17 '13 at 16:48

1: Try this before we proceed:

  1. Unplug your Time Machine backup device
  2. Open Disk Utility (Open Finder > Click Go at Top Menu Bar > Utilities > Disk Utility.app)
  3. Click on your main HDD at the left
  4. Click Repair Disk Permissions
  5. Enter an Administrator Username/Password and Click OK
  6. Once complete, plug in your Time Machine backup device and retry

If this doesn't work, then we need to checkout your logs files (instructions below).

2: How to view your Time Machine log files:

Time Machine keeps a log specific to each backup in the root directory of the backup.

To access its logs, do the following:

  1. Open Terminal (Open Finder > Click Go at Top Menu Bar > Utilities > Terminal.app)
  2. Type cd /Volumes/[Time Machine disk name]/Backups.backupdb/[Machine name]/Latest
  3. Type sudo nano .Backup.log to view the log file

Note: To view the "in progress" logs go into inProgress directories via Terminal you can also see the hidden log files if you type 'ls -al'.

Let us know what these log files say and we can better assist you with your issue.

3: Lets check the system log for the Time Machine's backup process.

I'm certain your issue lies with a single or a couple files that are not behaving nicely.

  1. Open Terminal (Open Finder > Click Go at Top Menu Bar > Utilities > Terminal.app)
  2. Type sudo grep backupd /var/log/system.log
  3. Report your results to your original post above
  • I repaired the Disk Permissions and unfortunatly nothing, so I've added what ever logs I could. Dec 10 '13 at 20:44
  • @EasilyBaffled are you still having issues with your Time Machine backups? If so, were you able to check the system log as outlined in step 3 above? Jan 2 '14 at 15:52

Judging by your log from back in October, lets try this:

  1. Log into the lego90511 user account
  2. Open Terminal
  3. Type cd ~ and Hit Enter
  4. Type sudo rm .appinventer Hit Enter, Enter Administrator Username/Password and hit enter
  5. Type sudo rm .DownloadManager Hit Enter, Enter Administrator Username/Password and hit enter

Now we'll also try adding an exclusion for Portal.app:

  1. Open up your Time Machine Preferences (Apple Logo > System Preferences > Time Machine > Options
  2. Click the + button and then head to your Applications folder
  3. Click on Portal.app and click Exclude
  4. Click Save
  5. Retry Your backup

Note: If the Options button in Time Machine preferences is grayed out, you need to unlock it by click the lock icon on the bottom left.

Report back here with your results.

In response to your question below, the only issue you could possibly run into by removing these files is losing some of the configuration settings of the application that created them.

In your case, you may lose configuration settings for AppInventer (which has since been deprecated by Google anyway) and for Download Manager.

Excluding Portal from the Time Machine backup will just tell it not to backup those files.

Note: If you're using Steam, I actually recommend you excluding all of your games from Time Machine backup since you can easily recover those items, including save files, directly from Steam. This will help speed up the backup process and also save space on your backup device.

  • Before I do this, what are the possible implications of removing .* files, specifically those files? Dec 11 '13 at 2:51
  • Ah so .* files are things created by the applicaitions and are not integral to the system. Dec 11 '13 at 15:00
  • Correct. Usually files or folders created in a User folder are not system dependent. They are, like you say, created by applications that are installed and configured by that user. Dec 11 '13 at 16:18
  • Unfortunatly that didn't work, and I can't see what's in the .inprogress file on the hard drive. Dec 12 '13 at 4:16
  • Try removing that file altogether (.inprogress) using rm in Terminal. Make sure you empty your trash as well before trying another backup. Dec 13 '13 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .