First of all I'd like to say that I've spent most of the day trying to figure this problem out. I've already read quite some articles on this issue but can't seem to find the specific issue I'm experiencing.

I'm running OS X 10.9 Mavericks on a Mac Mini. Our server is running Linux Gentoo. At this point I'm not exact sure which version.

The problem

When I connect to a server on our company network with the SMB or CIFS protocol I can mount the volumes from that server. I can also access and read the files on all the volumes (so far as I know). I connect through the admin username and password for this server.

However, when I try to copy files to one particularly volume I get prompted by Finder to enter my username and password. After I've entered my OSX user credentials I get an error stating the following:

The operation can’t be completed because you don’t have permission to access some of the items.

I therefor cannot copy files to this specific volume on our server. I can however copy files to other volumes on our server.

Attempted Solutions

Solutions I've already attempted are:

  • Connecting through CIFS rather then SMB
  • Changing the permissions on said files to read/write by everyone
  • Attempting to install Samba to be used instead of OS X's SMB implementation

None of these attempts have managed to solve the problem I'm experiencing.

Some more alternative attempts

What I also tried to do was to give my files to a colleague which runs OS X Mountain Lion so he could attempt to copy the files to said volume. He got the same problem and was also prompted by Finder to provide his credentials on which afterwards failed to copy because of the above permissions error.
He can however copy his own files to said volume without any problem.

When I provided my files to a colleague which is using Windows 8 he succeeded in copying my files to said volume.

TL;DR

Can't copy files over SMB to specific server volume from OSX Mavericks. Can read however.

Any help is very much appreciated.

Update #1

Some people have suggested that I needed to enter the server credentials in the Finder prompt but it doesn't allow that. I can only enter my OSX account credentials.

I also want to indicate that I connect to the server with the same user account and login as most of my colleagues. So I connect with the same account as colleagues which can copy files to the server. I, however, keep getting the no permissions error when I try to copy files to the server.

  • It may help to provide an example of the permissions that are set on the volume/share/directory that you're having problems with. You will most likely want to check the permissions on the server side using something like ls -al or getfacl. Are you specifying createMode or directoryMode options for that share in the server's smb.conf file? – Eddie Kelley Dec 14 '13 at 0:36
up vote 1 down vote accepted
+50

Usually the authentication prompt is in relation to the destination for your copy.

Thus, from what you're describing, you should enter your Gentoo login credentials. However, I suspect the owner/write permission are too restrictive on that specific volume. Have you checked owner user/group on the problematic volume vs. the other "problem-free" volumes? Are the read/write permissions the same?

To change the permissions without resorting to Terminal, highlight the folder you want to put the user file in and select Get Info (Cmd+i). At the bottom are the permissions. Make sure that where it says "everyone" that it also says "Read & Write." You may have to click the little gold lock at the bottom of the Get Info pane to adjust this. Once you do this, you will be able to copy your folder over.

  • You should be able to comment anywhere now.... – bmike Dec 14 '13 at 0:00
  • @bmike Indeed I am, thanks. – Lasse Dec 14 '13 at 7:57
  • Hi Lasse, thanks for responding. When I get the Finder prompt I can only use my OS X login credentials and no other. The Gentoo login credentials don't work. As far as I can see when I do cmd+i on various folders inside the Volumes on the server, they always indicate the same permissions: You have custom access. So I don't get the normal table with the user group names and privileges. – Dries Vints Dec 16 '13 at 8:29
  • Hi Lasse, after investigating further I've discovered that the permissions are indeed too restrictive on the folders I was trying to copy to (dr-xr-xr-x). I did some further investigation and apparently when I create a folder on the server it gets set to writeable only for myself while when a colleague creates a folder it gets set to writeable for everyone. That still doesn't explains why there are folders with the permissions I mentioned above. Is there any way to force the server to always create folders with write permissions for everyone? – Dries Vints Dec 16 '13 at 9:01
  • @DriesVints: Good job! That was what I suspected (That it was on the Linux-side). You can change default permissions, yes. I'm no expert on that but umask is what you'd usually use to change the settings. Keep security in mind, though. 777 should only be used when absolutely necessary. However, you should investigate the following: Which group(s) are you in that your colleague is/isn't? That very much affects permissions. This might be in the SMB software the server uses or directly based off Gentoo's own list. – Lasse Dec 16 '13 at 11:02

I had the same problem and I think I solved it:
You have to change the server address from smb to cifs, for example if your address is:

smb://ummsnas01/MarkLab$

…change it to:

cifs://ummsnas01/MarkLab$

That's it! Hopefully it works now for you too!

  • Hey Eduardo, thanks for your suggestion but this was one of the first things I tried and it didn't work. Lasse suggested it was a permissions problem and it turned out to be so. – Dries Vints Dec 24 '13 at 9:10

The solution in our case was to make the user account "mobile" on the local mac (we were having problems with a domain user not being allowed access to an smb share on a domain member server).

It was a problem on any Mavericks version where the domain user was not mobile.

Well at first glance I would say that your Linux Server should be in the future set up as a Active Directory with unique users and permissions set appropriately.

When you copy a file over and then you enter your OS X account information that is probably the stumbling block for the transfer. Entering the admin credentials for the Linux admin should allow you the correct privilege to write to the share on the SMB/CIFS share you are working on.

What is confusing that you say that your colleagues transfer files with their credentials.... so I am unclear if those are local system credentials or server credentials.

  • Hi Andrew, thanks for responding. When I get prompted to enter my credentials I can only enter the credentials for my OSX account. I cannot enter the same credentials I use to connect to the server. I might want to indicate that everyone here uses the same credentials to connect to the server. So I'm connecting to the server with the same credentials as people who can transfer files. To sum it up: I can connect to the server with the server credentials but when I get prompted to enter my credentials in the Finder window when I want to copy files I can only enter my system credentials. – Dries Vints Dec 16 '13 at 8:33

This would have been a comment too but I haven't yet enough reputation.

You're trying to use a Windows file sharing protocol for communication between Mac OS and Linux computers. Why not use file sharing protocols that are more native to the platforms you're using, i.e.:

  • install and use AFP (Mac OS's file sharing protocol) on Linux, or
  • use NFS (Unix's file sharing protocol, spoken well by both Linux and Mac OS)

The solution is simple. You must go to the SMB sharing settings and give proper permissions to the user with whose credentials you are logged from you mac. The default sharing permissions in windows is for everyone, but you must have the specific username permitted there.

For those who have come to this page in search of an answer to this problem, I've found the solution to my experience with this issue:

The HD that is connected to the network must be formatted in exFat. You can do this by physically connecting the drive to your computer and using Disk Utility to reformat in exFat. That solved my problem. I hope it solves yours! Cheers!

  • That sounds like it's server-specific - it shouldn't matter with Samba provided the HD is formatted using a filesystem the server "understands". I've used ext3 partitions as Samba shares on Debian boxes before and had no problem using them from macOS clients. – John N Feb 2 '17 at 10:08

I met the similar issue and the root cause was the SELINUX enable. You can disable the SELINUX and try.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.