2

I restored my iPod-touch 4 data to my new iPod-touch 5, and the calendar was looking good, until I realize it was not syncing.

I tried deleting my Google Account and creating again, twice, with no success (now the calendars and events are not even showing in the app).

Also, I tried both Google account and CalDAV account, but none of them are even downloading my calendars.

I use two-step authentication, and I'm using app generated passwords each time I try to add a new account to sync.

The GMail sync is working properly, only the Calendar have some problem.

Is there anything more I can try? Or should I restore and keep my iOS 6?

(By the way, the Reminders are not syncing with iCloud, and Safari is crashing as soon as it opens, even after a few restarts of the iOS. But the calendar is the big problem right now)

1

Go to https://www.google.com/calendar/syncselect and make sure that you have all of the calendars enabled.

See https://support.google.com/calendar/answer/151674 for more information --- However! Be sure to ignore the part about Google Apps unless you have a paid Google Apps account. Specifically do not use https://m.google.com/sync/settings/ unless you are using a paid Google Apps account.)

http://productforums.google.com/d/msg/calendar/G4ClHD46kP4/LekDrZoyCo0J is also helpful to understand the changes that happened when Google switched from Exchange ActiveSync to CalDAV. The author of that posts suggests https://www.google.com/calendar/iphoneselect and/or https://www.google.com/calendar/hosted/YOUR.DOMAIN.HERE/iphoneselect (the latter being for Google Apps hosted accounts). In my experience they all seem to lead to the same place, but YMMV.

If you have more than one Google Apps/Gmail account, but sure to log into the right one before you try any of this.

Last but not least, you may need to 'force quit' the calendar app on the iOS device (in iOS7, double-press the 'Home' button, then 'flick' the app off the top of the screen). My suggestion would be to start by deleting the Google account from your iOS device, then go and enable the CalDAV settings, and then re-enable the Google Account. That should give everything enough time to re-sync and notice the changes.

  • This is still the way to do it in iOS 11.4. – SSteve Jul 10 '18 at 15:46
0

Looks like the problem was due to the iPod 5 having been restored from the iPod 4. That installed iOS 6, and later I updated to iOS 7, with a lot of bugs.

Now I restored it to factory settings (iOS 7), and synchronized with iTunes without restoring from iPod 4, and everything is OK.

0

I had the problem of Google calendar not synchronizing on a brand new iPhone 5s. The Gmail account was setup successfully (all contacts and email were downloaded to the device), but the calendar was not showing or syncing.

I resolved the problem as follows:

  1. in SettingsMail, Contacts and Calendars, select Gmail account and uncheck the Calendars option, then agree to deleting from the iPhone

  2. Add a new account: pick Other, then new CalDAV account

    • Server is www.google.com
    • User is your Google account (including the @gmail.com bit)
    • Password
    • Description is whatever you like

After that, my Google calendar showed up as expected in the calendar app, and appointments would synchronize successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .