1

I'm using a Canon MX882 printer with Mavericks.

I can set and save printer presets and review them under show presets. All settings are saved as expected, but when actually selecting to use the preset just before printing thing don't quite work as expected. On my next attempt to use a preset, even though the "show presets" still shows the settings were saved as expected, the reality is quite a few of the settings will stick with the default settings.

For example, I will set Layout to 2 pages per sheet and set Duplex Printing and Margins to print two-sided. "Show presets" shows the setting were saved as expected, but when I exit and re-enter to print and select this preset (show preset still shows correct settings), the duplex printer setting won't take affect. That is, when I print it will only print single-side, despite 2-side duplex being enabled. The layout will be 2 pages per sheet, as expected.

If I manually set the printer settings as I want and print (without saving it as a preset) the document will print with the setting I chose.

Also, after selecting a preset I notice none of the printer settings actually change if I dive down into each setting. I'm not talking about the "show presets", but the settings below. I would expect those to change in conjunction with a preset change. This seems really strange, because I don't see how you could modify a duplicated preset or any other existing preset. However, visually the image in the page preview and page counts will change based on the preset I chose.

The only other similar problem I could find out in the net concerns getting the paper size setting to save in a preset. None of the solutions for this problem seemed to solve my problem. (I've seen Safari/print backgrounds not save into the preset, but that one is not a big issue for me.)

I've used the Mavericks/Apple provided drivers and those from Canon's site, but they both behave the same.

I've tried creating presets that work for only one printer and all printers, without any difference in behavior.

The one thing I have yet to try is to create separate printer drivers each with their own set of default presets by configuring the default printer settings via CUPS. I tried one experiment to use CUPS to modify a second copy of the printer driver with duplex enabled by default, but it seems the print utility still had the old print default preset settings (without duplex enabled). Not sure if I needed to reboot for the setting to take affect. I might have to revisit this workaround again.

I would really like to use the printer presets, is there something I am missing?

Right now I'm at my wits end. I'm very new to Mac, so I'm probably missing something.

1

I think I have a solution to this problem.

After upgrading to Mavericks my saved presets for a Brother Laser printer still worked fine, but for an Epson Inkjet they would load, like you describe. I thought it was the printer or OS conflict as the Epson was attached by USB to a machine running OS X 10.6 and I was sharing to the Mavericks machine. However I got a new wireless Epson Inkjet and the problem persisted.

Here's what I did to fix it.

  1. Log in to an administrator account. Make a new one if you need to and give it full privileges.
  2. Open an app that lets you print, Safari say.
  3. Type Cmd-P and select the problem printer, set your options and save the preset.
  4. Click Print, just to make sure it's working.
  5. Type Cmd-P and check that your settings have stuck, if they haven't try again with another user account, if they have carry on.
  6. Quit the App you used above.
  7. In the Finder Opt-Click the Go menu and select Library.
  8. Navigate to Preferences.
  9. Copy the file com.apple.print.custompresets.forprinter.[yourprintername].plist to the Desktop.
  10. Change the owner of the file to the account that is having problems (chown [username] com.apple.print.custompresets.forprinter.[yourprintername].plist) if this fails precede the command with sudo.
  11. Copy the file from the Desktop to the Drop Box of the user having problems (/Users/[username]/Public/Drop Box, or you could email it to yourself or use Dropbox (as in the cloud service).
  12. Log out of the admin account and back in to your usual one.
  13. Repeat step 7 and 8 above
  14. Delete the com.apple.print.custompresets.forprinter.[yourprintername].plist
  15. Copy your new com.apple.print.custompresets.forprinter.[yourprintername].plist from your Drop Box folder.
  16. Select the new file and type Cmd-I. Scroll down to the bottom of the Get Info window and check that your current username is the one listed with Read/Write access.
  17. Log out
  18. Log back in
  19. Try to print something. Hopefully you will now have a working preset.

Hope this is useful

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .