I find really annoying to use Midnight Commander under OS X when using the non-extended keyboard (laptop).

I found no way of simulating an INSERT key press (select file) and I would like to find a solution that does not require me to reconfigure MC, specially because I cannot do this with each machine I'm connecting to from my MacBook.

I will give extra bonus ;) for and extended solution what will solve the problem not only for the INSERT (select file) but also for switch selection and add/substract selection (NumMultiply,NumMinus,NumPlus).

Remember that Numlock area *, + and - are not the same as the ones from the standard keyboard.


Ctrl-T is standard hotkey for file selection — http://linux.die.net/man/1/mc.

As for switch/add/substract, just type shift-8 for *, shift-= for + and - for minus.

All this works in MC out of the box.

  • ^T works but the others do not and I tried to use an external keyboard and when I press *, + or - from the keypad it will work.
    – sorin
    Apr 4 '11 at 13:32
  • That's strange. Works for me though (with iTerm2). What happens then? Make sure your command line is clear when you do that. Apr 4 '11 at 13:51
  • Interesting, I am also using iTerm2 and pressing the keypad *-+ it doesn't bring the selection window.
    – sorin
    Apr 4 '11 at 15:00
  • That's all I can help you with, unfortunately. Apr 5 '11 at 12:39
  • I have problem to prevent Unselect dialog when pressing minus, did anyone solve this apple.stackexchange.com/questions/337008/… ?
    – brablc
    Sep 20 '18 at 11:31

Control+T will select files:



For those like me who were drawn here by a Google search based on the title of the question (not relating to Midnight Commander), I still haven't found a great solution. However, for Word processors (a common usage of needing to find the "insert" key to toggle Insert/Overwrite mode), you should be able to click the text that says "INSRT" or "OVER"/"OVWT" in the status bar on the bottom of the Word Processor to change modes, as detailed here for Open Office. Not awesome, but at least functional.

If neither Midnight Commander nor a Word Processor drew you here, then...good luck in your quest!


Holding shift ⇧ while pressing or will also select the file.

Shift ⇧ + is easier for me to reach and skip over files I don't want to select compared to Control ⌃ + t.

  • Doesn't work for me. Mar 8 '21 at 18:04
  • 1
    @SergeyKirienko I guess you're using the native OSX Terminal app? There's something about the native Terminal app that doesn't send Shift + Arrow keystrokes correctly (probably you need to fiddle with some settings in Terminal or in OSX System Preferences). You might want to try iTermlink . iTerm works out of the box with Shift + Arrow. I've tried the above Shift + Arrow and it works locally (with homebrew version of mc) and also through SSH/mosh/tmux.
    – slackair
    Mar 15 '21 at 2:46

For those who want to select all files: first press Shift++ - Midnight Commander will prompt for a selection options (* by default), then just hit Enter - works fine in Terminal.app

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .