I'm on 10.9, and I had been using internet sharing successfully again for the first time since Lion. Today though, it just decided to stop working again.

Network layout:

Modem -ethernet-> Router -ethernet-> Mac Pro -ethernet-> MacBook Pro Retina

The internet works fine on the Mac Pro, but it is no longer forwarding the proper DHCP settings to the MacBook.

Previously, the MacBook would get the IP address of, and was able to surf the web fine. (Though it wasn't able to connect to any AirPlay/AirPrint devices while on the ethernet interface)

Sometime today, a setting got messed up, and I'm not sure how to fix it or what setting it is.

The MacBook now has a "Self-assigned" IP of, even though it is set to use DHCP. The ethernet port on the Mac Pro that the MacBook Pro is connected to is showing a "Self-assigned" IP of, even though it is set up to use DHCP as well.

The internet sharing options appear to be correct: share connection from Ethernet 1 to Ethernet 2.

But alas, for no apparent reason, I'm not getting internet access.

3 Answers 3


Okay, so I got it to work again. I had to manually enter the correct DHCP, IPv4, and DNS settings on the MacBook Pro.

Here are the settings I used to get it to work in Network Preferences on the MacBook Pro:



I had previously tried to do this manually, but I only tried the IP address stuff, I didn't think about entering in the DNS server until I read this article: http://forums.beyond.ca/showthread/t-216916.html

It's dumb that I have to do this manually now, and that I still am unable to see AirPlay/AirPort devices.

  • Yeah this is the only way I can get it to work as well. I have a problem with wifi. If I get the macbook to forget the network and rejoin, I get a proper IP address. However as soon as I try to go to any website, the IP becomes self signed again.
    – Allen Zeng
    Commented Feb 12, 2014 at 7:35
  • This fixes the symptoms but not the problem. The problem is your DHCP server or servers aren't handing out DHCP information any more. Your solution, while valid, solves the DHCP problem by not using DHCP.
    – Mei
    Commented Jul 6, 2015 at 18:01

Very good reply, it solved my problem.

However, how do you find the address you need to use for the manual configuration of the WiFi client?

The way I found the one that works with my system was to start a Terminal window and type

ifconfig -a

then look for a "bridge" interface with a valid inet (IPv4) address. I then used another address from the same network (e.g. if the bridge has you specify and follow the instructions given above.


Following the instruction here everything went back to normal again:

Backup these 2 files:

/Library/Preferences/SystemConfiguration/NetworkInterfaces.plist /Library/Preferences/SystemConfiguration/preferences.plist

Then delete these 2 files and reboot

The reboot took quite a while for me though.

  • A simple reboot worked for me.
    – khatchad
    Commented Sep 24, 2014 at 12:18
  • No need to "back up and delete" - just rename the files, such as putting a .sav at the end. By renaming, you make the original files vanish and put them in a form that can be used to recover as needed.
    – Mei
    Commented Jul 6, 2015 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .