I had a cheap NAS that I was using that would give me an Error with code -50 whenever I tried to copy certain directories of files to it. At first I thought it was just the NAS device. Recently I bought a Drobo 5N hooked it up to my network, now I am getting the same errors for the same folders which makes me think it is an OSX issue.

Has anyone seen this before and how do I fix it?

My debugging steps:

I have tried the same process from two different computers and both give the same error.

I have tried copying the files to a local drive or another DAS and they copied fine.

I have created an isolated network with a small switch and just my computer and drobo plugged into it and the same error occurs.

I also have tried through 2 different switches and through just a Time Capsule but the error persists.

Any ideas?

  • I have the same problem with a Seagate Central Storage 4TB NAS. This wasn't happening till a few days ago, but now I have to copy files and not directories, or it just throws the error and stops.
    – aalaap
    Feb 14, 2014 at 8:40
  • @aalaap I added the answer that worked for me below - please let me know if it helps or not.
    – xizor
    Feb 15, 2014 at 13:32
  • nope, sorry, it didn't!
    – aalaap
    Feb 18, 2014 at 9:37

2 Answers 2


The problem for me was that there were several invisible .appledouble folders within the folders I was trying to copy.

These folders are written by OS X for compatibility with Apple Finder Metadata with some NASs but are safe to be deleted (at least in my case). I just removed them all and everything was back to normal.

You can automate the process by typing the below into terminal when your pwd is the external drive. Please only do this if you are comfortable with the terminal - otherwise you could end up deleting important things.

find . -name \.AppleDouble -exec rm -rf {} \;
  • Nope, this didn't work for me. :-( I ran the command (even as sudo) and it seemingly removed all those AppleDouble folders, but I'm still unable to paste even 5-6 folders into the NAS. I'm simply using a Windows laptop to haul files over now.
    – aalaap
    Feb 18, 2014 at 9:36
  • Odd, depending on the NAS it might also use .AppleSingle files. Are there any hidden files/directories in the folders you are having trouble copying?
    – xizor
    Feb 18, 2014 at 18:30
  • Nothing extra apart from the usual DS Store and Thumbs.db type stuff. I eventually just managed to move 500GB+ data using Windows.
    – aalaap
    Mar 3, 2014 at 9:33

I had the same problem, but that was to due to the presence of @eaDir files. The drive had been once connected to the sinology which had created those file automatically. You can delete the @eaDir (see xizor's solution) or use Carbon copy cloner, asking it to exclude @eaDir files while copying folders.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .