1

I'm using a 27" iMac with Mavericks. About 2 weeks ago, Messages stop creating notifications whenever I received a message from someone. I used to get a notification in the upper right corner of the screen if Messages was in the background, but now I don't get anything. As a result, when people send me IM messages while Messages is in the background, I don't see them until later when I see the Messages window.

I didn't change any settings or anything like that. They just stopped showing up.

I don't see anything in the Messages Preferences about turning Notifications on/off either.

  • when you say "in the background," do you mean as in it is open, but in the back? Or do you mean minimized? – user2277872 Dec 6 '13 at 0:38
  • Background as in "not the active window". Doesn't matter if it's minimized or not. – Jake Wilson Dec 6 '13 at 18:07
2

The issue might be the way that you have your notifications for Messages set. If you go under Notifications -> Messages, you will see something that says "Messages alert style:" and will have the option to select None, Banners, or Alerts.

Make sure you don't have "None" set as your alert style. You can also set the badge counter to show for when you get a new message by clicking the "Badge app icon" option lower on the screen.

  • Yeah it was already on Alert. It started working again after restarting the computer. I have no idea what the problem was. – Jake Wilson Dec 6 '13 at 22:16
  • Oh, well I'm glad it's working now – user2277872 Dec 6 '13 at 22:18
1

Just a suggestion, because this was how I ended up fixing mine:

You need to go to Spotlight > Activity Monitor > Search "Notification" > Press Quit

It reboots the notificaton center. If you want it, there's also a youtube video that's only 19 seconds that shows it: http://www.youtube.com/watch?feature=player_embedded&v=UeXx42iGUs4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .