15

A friend had an iPhone and when I added her contact I set it her number as "iPhone". She's recently got an Android device but my iPhone keeps trying to iMessage her, needless to say she's not getting my messages. I can obviously press and hold each message and "send as SMS" but I'd like a more permanent solution.

How can I make my phone always send messages to her by SMS?

  • Presume that her number remains the same? – stuffe Dec 4 '13 at 15:54
  • Did she, by any chance, enable receiving messages on that number on another iOS device or a Mac? – Jozef Legény Dec 4 '13 at 16:15
  • @stuffe yes. same number – Greg B Dec 4 '13 at 16:20
  • @JozefLegény maybe. I'll check. – Greg B Dec 4 '13 at 16:20
  • 1
    The infuriating part of this issue is that you cannot do it for someone who neither knows nor cares if you are having an issue with SMS/iMessage. You cannot unilaterally exclude their number from iMessage, you need their complicity & active participation. – Tetsujin Nov 9 '14 at 16:50
14

To dissable iMessage on your phone (the one who has changed from iPhone to something else): http://support.apple.com/kb/ts5185

Your friend can also de-register their phone number from iMessage after the fact at https://selfsolve.apple.com/deregister-imessage

As long as their SMS number is associated with iMessage via their Apple ID, iMessage delivery will be preferred by iOS when sending. If you must send an SMS without them fixing their account, you can turn off iMessage entirely on your iPhone and then send a SMS via your cellular carrier to that contact before turning on iMessage again if you wish to have that for other conversations.

  • This is the only way +1 – Rob May 8 '14 at 6:40
1

It seems like there are one or two convoluted methods to manually reset a given contact's phone number to stop sending iMessages to them, involving switching the iMessages setting on and off and rebooting and resetting the phones while also deleting the contact and manually adding it again on one of the iPhones. That way seems pretty crazy, and I hope Apple figures out a better way to resolve this issue.

Meanwhile, if you send a message to a non-iMessages user, and the message shows a red exclamation point (showing it didn't send), you can tap on the exclamation point and choose "Send as Text Message". Do this two more times to the same contact, and it seems the Messages app finally catches on that you only want to send text messages to this particular contact.

  • It may temporarily recognise that, but the next time you send them a message it tries to go thru iMessage again. – Madivad Mar 25 '14 at 7:17
  • @Madivad - True, but at least for short conversations, it seems to work okay. In the end, Apple is really responsible for this mess—they should make it right :( – geerlingguy Mar 25 '14 at 12:22
  • I've tried the 'send as SMS' trick more times than I care to think. It seemed to work in iOS 6 - but 7 & 8 are just getting progressively more insistent that the number I'm sending to is an iPhone number. Its owner claims it never has been. – Tetsujin Nov 9 '14 at 16:47
1

Double click the text if you have already sent it. Then you will have an option as sending it as a text messages and hopefully it will go through.

  • Not in iOS 8, that's for sure :( – Tetsujin Nov 9 '14 at 16:44
  • A long click on the sent message will propose "Send by SMS or MMS" just after you press the "up arrow" button to send it. Just tap this choice – lauhub Jul 16 '18 at 20:20
0

You might want to try heading over to your iMessage setting (located in Settings > Messages) and toggle the switch to turn iMessage off then back on again. That may possibly reset the affiliated contacts.

  • 1
    That in no way would fix the problem. The only way that would help Is if the user (sender) left it turned off – Madivad May 3 '14 at 1:21
  • @Madivad I'm providing a possible solution, not a definite answer. – user17805 May 4 '14 at 1:45

You must log in to answer this question.

protected by Community May 8 '14 at 6:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .