4

I have an iPhone 4s and am running iOS 7 on it. When I take a picture with the "process" filter, it then displays in place of the photo a blank screen. It doesn't happen when using the camera without a filter. Why is this happening, and what can I do about it?

5
  • Very interesting. First, are you on iOS 7.0.4? Second, I just tested every filter (on my iPhone 4S) and didn't get that problem so I would think it's not an iOS-wide bug - do you find it saves a blank photo when you take a picture with any other filters? One thing is I would recommend restarting your device, if you haven't already. Lastly, is it possible to take a photo, and then edit it with the "Process" filter, and have it save and appear correctly? Dec 4, 2013 at 3:02
  • @bassplayer7 Yes. I'm using 7.0.4 . In my house, we have 3 iPhone 4s phones and 2 iPhone 5s phones. The 5s doesn't have any problem with the filters. However, all 3 of the 4s phones will just display the picture as a white blank screen. So it may be a bug with the 4s. We have restarted the devices as well, to no avail. Dec 4, 2013 at 11:56
  • Since all the iPhone 4S's have that problem, I suspect it may be difficult to truly work around, and you may be stuck with post-processing the images. I would guess that it is due to memory or processor differences between the iPhone 5S's and the iPhone 4S's. While I don't think it will make a difference, you could exit all apps that are running in the background - except the camera - and then test. Also, just to confirm, have you tested with HDR on/off? It would also be interesting to pull those images to a computer to verify they are truly corrupted, and not just displayed incorrectly. Dec 4, 2013 at 15:50
  • @bassplayer7 Tested with HDR on/off. It caused the same problem. Also, when I share the images to my family's iCloud photo stream, the same problem happens. Maybe Apple will put out a fix in iOS 7.0.5. Dec 4, 2013 at 16:29
  • That's all I can think of to try. I suppose you are stuck editing the images after they have been taken. If you would like to continue down the fix route, you could always submit feedback to Apple, and you could also take it to an Apple store for help. Dec 5, 2013 at 14:20

4 Answers 4

1

Here's a workaround: View the problem photo in your camera roll, click edit, click rotate twice to make the image upside down. Click save. Click edit again, rotate back to normal, and save. Now you have your image back!

Not sure what causes this, but I have the problem also on my 4S. I did find that closing all the apps and rebooting helps.

1

If you have tried all the above with resetting your camera settings and iPhone settings you might need to restore the whole iPhone. I used to see this a lot in iOS 3 and 4 where you could take pictures but they save as blank/white images. Fix was in those OSes and iDevices to DFU restore the sucker without restoring from a backup sorry to say.

1

I had the same problem with my iPhone 4s. If all the iPhones are connected to the same iCloud account, you have to wipe out everything and start over (as the apple store told me). I had a warranty on mine, and went through about 4 different iPhones with the same problem, including the camera not even working at all and just showing a black screen. Then, the apple store told me they had done everything they could and the only thing to fix it would be to wipe out all information and set up a new iCloud. I can't tell you if it worked or not because I didn't want to lose everything so I never fixed it.

1

Opening it and tapping "edit" brings it back but you have to apply another filter or magic touch for it to stick around.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .