11

Lately, when I click in "Apple TV" (trying to select it as default sound output), OSX changes it back to "Internal Speakers".

sound settings

10

much simpler command:

sudo pkill coreaudiod
4

Just had this problem myself, and this solution worked for me: Open a terminal and kill the audio driver, it will restart and everything should work straight away.

sudo kill `ps -ax | grep 'coreaudiod' | grep 'sbin' |awk '{print $1}'`
  • Would you know how to create a scriptfile with this command, and also how to supply my password in the command? It ask for my password when using it in terminal. Thanks – Jaqenhghar Feb 10 '14 at 19:04
3

sudo killall coreaudiod is easier.

0

Disable and enable wifi.

This avoids killing coreaudiod.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .