1

When I have Microsoft Word on one “space” (virtual desktop in usual english), sometimes clicking anything on another “space” forces me to go back to the "space" where the Word window is opened. How can I prevent Word from behaving this way?

2

Note: This is a blind answer attempt: I don't have Microsoft Office on any of my computers.

Could you try:

System Preferences
    Mission Control

to deactivate:

    ☐ Automatically rearrange Spaces based on most recent use
    ☐ When switching to an application, switch to a space with open
               windows for the application

I deactivated both because they were always disturbing my working environment in a way I wasn't able to go ahead with what I was running in parallel on many spaces. Since I made this setting I'm able to work with an environment not running under my feet.

0

One key issue I find with this is that in many cases, the spacing is actually not happening, you are getting the results of a justification issue. If you go into Microsoft Word, then click on the Word item, top left, and then open preferences (this would normally be "options" on a Windows machine) go to Display or View. This area will show you items you can list as visible in word when you work. Check the box for "show spacing" and you will then notice a tiny pip like mark between words in your word doc.

If you are in fact getting double spacing, it will show as two pips, and you will be able to identify if it is a keyboard issue, or if it is something else. If there is only ONE pip every time, then try left justifying the text, and it will compress that spacing down to be uniform instead of being spread out.

Sorry if I didn't get the names of the menu items above correct, my Macbook Pro happens to be in for repair, so couldn't double check on my machine.

  • 1
    I think the original question isn’t about space managment in text within Word but about virtual desktops managment which Apple chosed to name “Spaces”. – dan Jul 20 at 10:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .