6

When I insert my USB Pendrive in my iMac i see this message: enter image description here

I tried to format it both with DiskUtility and with diskutil command in terminal but I get this error:

iMac:~ User$ diskutil eraseVolume HFS+ PenDrive disk2
Started erase on disk2
Unmounting disk
Erasing
newfs_hfs: WriteBuffer:  pwrite(3, 0x108551000, 131072, 0): Device not configured
newfs_hfs: write (sector 0): Invalid argument
Mounting disk
Could not mount disk2 with name (null) after erase
Error: -69832: File system formatter failed

How can I solve it?

  • Have you tried formatting the drive on another OS? – Vincent Dec 3 '13 at 1:55
  • As a test to see if the drive memory is good, try formatting it FAT32 instead of HFS+ and see if that works. – ArchonOSX Dec 14 '13 at 16:37
1

You could try booting into any free Linux livecd with Gparted on it, or this one called Parted Magic which is designed for disk maintenance tasks like this. (it costs a tiny $5 though.)

Do note that you may not be able to format as HFS+ using linux, however if you choose a compatible file system like FAT32 you'd be able to read/write to the drive in most OS's.

1

Click on "Initialize..."

or if the useer your login with can adminastrat the computer then try adding "sudo " and entering your password when prompted.

So:

sudo diskutil eraseVolume HFS+ PenDrive disk2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .