2

I ran codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app as per a post here and now I cannot launch Bootcamp Assistant at all. Is there a terminal command I can run to reverse this?

1

There is no undo; permanent changes are made. The only way to resolve this situation would be to replace Boot Camp Assistant with a known-good copy. A simple way to do that is to reinstall OS X using Recovery Mode.

| improve this answer | |
  • That's a pity. Would obtaining a fresh copy of bootcamp asst. work or is this a change made outside of the bootcamp resources? – user2528531 Dec 2 '13 at 10:30
  • @user2528531 The code signing is done on the .app package, and restoring this should be fine since you did not create a specific certificate or any other external resources to perform this. If you have a Time Machine backup, you can use this to restore the file. Alternatively, use an OS X installer and Pacifist to extract the Boot Camp Assistant. – grg Dec 2 '13 at 17:09
  • Thanks very much. That worked although I can't copy the restored version to the utilities directory because it won't let me over write the original. It works run from another directory though. – user2528531 Dec 3 '13 at 10:09
  • hey man same problem happened to me can you share the bootcamp in drive ? – Achraf Apr 24 at 22:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .