2

I'm trying to do a fresh install of OSX on a new hard drive and the MacBook keeps ejecting the installation DVD. To see if the dvd reader has the problem itself, I tried another random dvd. The problem is it didn't get ejected and now I'm stuck because holding down the eject button doesn't eject it. I can hear that it is being read though.. since the hard drive is new, there is no OS in it so I'm stuck with the blinking question mark upon bootup and I can't also eject the random dvd i put in.

Any ideas what to do?

0

Okay, I decided to just take the plunge and took it apart.. After opening the optical drive itself, the DVD seems to have been lodged badly so that's how I got it out.

  • Thank you for the question and answer. Can you expand on 'lodged badly'? Did the installation disc work once you got the other disc out? – D A Vincent Jan 2 '14 at 7:25
  • Well it seemed the optical drive tried closing the the cover even if the disc was only 75% inside the drive. So it pretty much held the disc in place and started trying to read it. That disc had quite a lot of scratches when I got it out. Horrible stuff. And yeah, the installation disc worked after I took apart the optical drive. – Propeller Jan 2 '14 at 7:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .