I have a Haswell retina MBP, but following the installation process with Bootcamp Assistant v.5.1.1 results in an error when Windows attempts to install. Are there any guides available that walks one through this process?


2 Answers 2


This is how to fix the bootcamp windows install error:

"Windows could not update the computer's boot configuration."

Do not try to fix with a workaround - you'll find solutions of people manually selecting their Windows partition during reboot by holding down the OPTION key. This will work, but you are circumventing the way that apple wanted you to install it (via EFI).

The solution to this error is simple: it's a PRAM problem. I've seen a lot of different ways of people claiming to fix this problem. I've experienced it multiple times on my Haswell 15" retina Macbook Pro, but it seems to be affecting a lot of the other Haswells as well.

Here are the steps:

  1. Create a USB install like normal using Boot Camp Assistant (include the Apple support software)
  2. Partition your drive for OSX and the new BOOTCAMP partition
  3. Let it automatically reboot, follow the normal procedures to format the new BOOTCAMP partition, and get to the "finishing" step during the Windows installation. You will get the error
  4. At this point, when you press OK it will automatically restart after 10+ seconds. When that happens, quickly hold ALT+COMMAND+P+R. You will see your screen flicker and you will hear the bootup sound twice, which means you reset the PRAM successfully
  5. Your OSX install should now boot instead of the failed Windows install
  6. Open Boot Camp Assistant again. Remove the Window partition that was created and restore OSX back to the partition size it had at the beginning of these steps
  7. Go through the Boot Camp Assistant once more to create the BOOTCAMP partition. You do NOT have to recreate the USB, so just uncheck and skip those steps
  8. Let it automatically reboot and follow the same Windows installation steps as before. You should not get the error the second time.

I found that this is the only thing that consistently works for me. I've installed Windows 8 and 8.1 on Mavericks 10.9.2 Haswell Macbook a bunch of times, so I'm pretty sure of it. This will result in you installing it as Apple meant it to be installed.

  • Wow now I'm tempted to to reinstall windows 8.1 on my mac just to see if this works... Commented Apr 7, 2014 at 8:53
  • Just confirmed this works on the 2013 haswell mbp 15" retina, I used Win8.1 pro (recent apr-may release). Thanks a lot @RalphN Commented May 20, 2014 at 18:43
  • I can confirm that this is working on a MacBook Pro retina 15 late 2013 Commented Jul 8, 2014 at 20:25
  • Thanks a lot! I tried so many different distributives, and finally your solution worked!!! Thanks again! Commented Aug 14, 2014 at 22:01
  • Thanks! Can confirm this works well on a MacBook Pro Retina 15" Mid 2014. Used Windows 8.1 Professional. Commented Nov 3, 2014 at 13:37

This is what I found to work:

  1. Create USB stick using Apple Bootcamp Assistant (and keep it in your machine for the duration of the installation). Follow the entire process (including specifying the size of your Windows partition).
  2. When Bootamp Assitant reboots your machine you need to interrupt the installation by holding option until you get a choice of what disk to boot from and select Macintosh HD.
  3. Open Disk Utility, select the drive above Macintosh HD (it should be specifying the size of the disk as a whole [for me it is 1 TB APPLE SSD SM1024F Media) then choose the partitions tab. Note: If you merely select Macintosh HD you will not see the Partitions tab. Important: If you partition the drive any other way with the same partition type it will not work, I initially couldn't find the partitions tab so I did something similar, but the installation process merely failed later. So you must do it this way.
  4. Once in the partitions drive, the BOOTCAMP partition should be at the bottom. Select this partition by clicking on it. Ensure it is the highlighted partition then press minus to remove it. Click apply on the bottom right to save the changes.
  5. Now press plus to add a new partition. Select this new partition and rename it to BOOTCAMP and change the partition type to ExFAT. Click apply again to save the changes.
  6. Reboot you Mac, press option again during the boot and this time select the Windows device with the USB logo on it. It's orange.
  7. The install process will start. If you happen to have a Windows 8 key but are installing Windows 8.1, your key won't work, use a generic key from here to get by the installation (you can change your product key once you have Windows running from Settings).
  8. When it gets to the list of partition you should see four of them. You want the last one. It will say it cannot install on the partition, so make sure the 4th partition is selected and format it. Once done, you should be able to continue the installation process.
  9. During installation it will recommend default settings. Specify advanced configuration and turn off Auto Updates. It is recommend it remain off until the bootcamp drivers are installed. When it is finished prepping the install it will reboot.
  10. It will reboot 2 or 3 times during installation. Each time it reboots you will need to intervene by pressing option but from now on select the silver Windows hard drive. Do not unplug your bootable USB until windows has been completely installed (BootCamp drivers are used from it).
  11. At the end of the installation it will prompt you to install the Apple Bootcamp Drivers, do it.




  • I followed your steps, but I'm getting a 'Windows could not update the computer's boot configuration. Installation cannot proceed.' before the first reboot. Any ideas why this is? Commented Dec 29, 2013 at 21:08
  • I think I ran into this very issue as well and it turned out that I was not configuring my partition correctly. Double check step 3 and ensure you are following it exactly. Specifically, you should be clicking on a the partitions tab before specifying format options.
    – Stunner
    Commented Dec 30, 2013 at 3:57
  • yeah still the same problem, did you boot EFI or BIOS? Commented Dec 30, 2013 at 15:16
  • 1
    OK I think in my previous attempt I accidentally booted from the original Win8 DVD instead of the bootcamp USB, it seems to be working now following your steps exactly, though only in BIOS mode not EFI. Seems to work now, thanks a lot! Commented Dec 30, 2013 at 15:44
  • 2
    i've added my answer, please read. I recommend avoiding solutions that force you to manually partition disks, or manually select partition for install. You might end up bypassing EFI install which will work, but isn't how apple intended.
    – Ralph N
    Commented Mar 20, 2014 at 3:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .