After update to iOS 7.0.4 from version 5.x, my iPad's battery has only fraction of full charge as fast as in 24 hours. I also noticed that iPad is staying warm even after several hours of idle time with a closed Smart Cover. I still failed to accept iCloud Terms&Conditions, as it always reports 'Unable to connect to server'.

What I already tried with no result:

  • disable bluetooth
  • turn Off Location Services
  • under Location Services, made sure no apps used GPS within last 24 hours
  • turn off Automatic Updates
  • enabled Accessibility>Reduce Motion
  • disable Background App Refresh
  • in Spotlight Search, keep only Applications; disable everything else
  • clear any launched earlier, to make sure there's no apps remaining idle in the background

2 Answers 2


yurkennis! I haven't seen that problem with iOS 7.

Have you tried restarting or resetting your iPad?

Restart: Press On/Off button until the Slide to Power Off slider appears, select Slide to Power Off and, after the iPad shuts down, then press the On/Off button until the Apple logo appears.

Reset: Press the Home and On/Off buttons at the same time and hold them until the Apple logo appears (about 10 seconds).

If these don't correct the problem connect to iTunes and do a restore.

If all else fails to do so:

In Settings, turn on Airplane mode, then reset your device by holding Power + Home button 15 seconds until you see the Apple logo. Power back on, then turn off Airplane mode.

  • Restarting: yes, of course. Reset: can I be sure that all settings, apps and data (including photos, videos and music) will be restored if I invoke iTunes backup just before the reset? Resetting in Airplane mode: could you elaborate how is that different from a normal Reset?
    – yurkennis
    Dec 1, 2013 at 18:03
  • Yes it will be restored in ITunes backup. Resetting in Airplane mode also resets SMC for the battery.
    – AppleDevX
    Dec 2, 2013 at 2:46
  • I tried to follow your instructions until "restore from iTunes". At that point iTunes asks to turn off Find My iPad, which I am unable to do as long as whole iCloud section in Settings keeps asking me to accept Terms & Conditions which never show up ("Unable to connect to server"). I already tried to install Find Friends to work around that, but uninstalled it soon hoping the problem has gone. But it hasn't, and reinstalling it doesn't solve the problem any more.
    – yurkennis
    Dec 6, 2013 at 21:44
  • ...For now I skipped restoring from backup, and proceeded to SMC reset. Will see whether it will help.
    – yurkennis
    Dec 6, 2013 at 22:02

My problem solved with this setting: Settings > General > iPad cover lock/unlock: On.

Either I messed up with settings after upgrade, or upgrade itself changed these settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .