2

Since updating to Mavericks, the buttons on the Apple apps have all lost thier icons:

Safari doesn't show any icons on the buttons

Can anybody advise how I can restore them?

Macbook Pro
13-inch, Early 2011
Processor  2.7 GHz Intel Core i7
Memory  8 GB 1333 MHz DDR3
Graphics  Intel HD Graphics 3000 512 MB
Software  OS X 10.9 (13A603)
  • Two questions. Did you photoshop the menu bar or install a tool that modified it? Does Safari and Mail have this problem if you create a new second account on your Mac and log in to that account? – bmike Nov 30 '13 at 15:06
  • I didn't Photoshop the menubar - as far as I'm aware I haven't installed anything other than the Evernote, and that was a while ago. When I sign in under a new user account, I can see the icons no problem. – bodacious Dec 1 '13 at 2:01
  • The usual answer for weird behavior like this is to repair permissions on the main drive. I don't use Mavericks yet, so I can't confirm this, but I assume that it's still in the Disk Utility app. – Bobson Dec 4 '13 at 22:51
  • @Bobson - thanks for your suggestion. Repairing the permissions hasn't helped though :/ – bodacious Dec 6 '13 at 8:46
  • You might try Control-Clicking and selecting customize toolbar, then remove and put everything back in. There's a good chance that won't work, but it's worth a try. – Zoyt Dec 7 '13 at 0:48
1

Given that the issue is limited to your user account, I would assume the problem lies within your home directory. Per this MacRumors thread, have you tried deleting ~/Library/Preferences/com.apple.systemuiserver.plist? I can't replicate your issue, but I have deleted this file seemingly without untoward effect on my 10.9 system.

By way of further diagnostics, you might also try Safe Booting by holding the Shift key on startup and see if the problem still occurs.

  • I'd like to add that restarting with "reopen windows when logging back in" unchecked may help. – wrossmck Dec 10 '13 at 19:21
  • Thanks @tullyhansen - I tried both of these but to no avail :( – bodacious Dec 11 '13 at 8:39
0

Try clearing the user and system caches, including the font caches. Corruption of caches can cause display problems.

Something like http://yasuapp.com or http://www.maintain.se/cocktail/index.php can clear the caches easily.

  • Thanks - I downloaded Yasu and ran the full clean. Still seeing the same issue :( – bodacious Dec 9 '13 at 12:39
0

Have you tried making a Time Machine backup, reinstalling OS X and then restoring from the same backup? It's unideal, I'll give you that. However, this is a surefire way that your problem will be repaired.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .