2

I have Excel 2008 installed on my Mac, which I recently upgraded to Mavericks, migrating all my settings across.

Previously (on Mountain Lion) when I entered a date like 11/12 this was interpreted as 11 December, but now Excel insists on interpreting this in American format.

All my existing data (some going back years, originally entered in Windows) displays correctly as I have entered a custom Format ddd dd/mm/yy, but displays incorrectly in the formula bar.

As far as I can tell, my system settings are correct for Australia - they were migrated across, and I have since checked. Numbers seems to have no problem with dates.

  • I've got the same problem too, so you're not alone. Language & Region settings are correct, but Excel still assumes date input is in US format, so, e.g., entering 6/1/14 produces the date 1st June 2014. (Default date display format in Excel also changed to MM/DD/YYYY, which I'm 99.999% sure wasn't the case before, though I'm not reinstalling everything just to double check.) It's driving me nuts. – Tom Seddon Jan 6 '14 at 1:31
1

After some searching and trial-and-error, I have identified that the issue relates to the absence of a key file: com.apple.HIToolbox.plist, which for some reason is not created when setting up a new User account (and may not be copied across if importing from another computer). Luckily this file is created when opening the Guest account, which can then be copied across to all required User accounts.

Here is a detailed summary of the procedure I eventually used to fix this date format issue:

  1. Create and open a Guest Account (if not already enabled, go to Users & Group Preferences)
  2. Go to the Library folder (it’s a hidden folder, so to find it, use Finder to go to the home folder, then select from the menu ‘Go:Go to Folder’ and type in ‘Library’)
  3. Go to the Preferences folder
  4. Make a local copy of the file: com.apple.HIToolbox.plist (e.g. onto an SD card, or external/cloud drive)
  5. Now open your desired User account
  6. Go to your Library folder (again it will be hidden, so find it as above)
  7. Go to the Preferences folder
  8. Copy the file: com.apple.HIToolbox.plist (from local storage) into this folder
  9. Quit Excel and then log out of your user account, and then log back in
  10. Next time Excel starts, UK date format will be correct!

(Source: http://www.yellowsbest.com/solved-uk...excelmac-2008/)

  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. Also, please don't use AD to just get more traffic for your own site. – nohillside Dec 11 '16 at 9:09
  • This worked for me, although I also needed to reboot the machine as a final step. – Ashley Aug 5 '18 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .