6

I have to keep AFP running for my TimeMachine backups, but would like my file shares to use SMB2 because it is much faster (better than double write speed in my tests).

Is there a way to make Mavericks use smb2 for file shares first?

UPDATE: The NAS shows up in my shared drive list in finder, from there the shares are clicked on and auto mounted. When SMB2 only is turned on the drives auto mount as SMB2, when AFP is also turned on the drives only auto mount as AFP.

  • What steps do you take to mount the share? – bmike Dec 5 '13 at 11:30
  • I have updated the question. – gbrandt Dec 5 '13 at 16:13
10
+50

When you access a file share, you could try using CMD + k in Finder (Connect to server), and then type the address as a CIFS or SMB path - ie. cifs://my.server/SomeFileShare or smb://my.server/SomeFileShare

Disclaimer: I don't have Mavericks, and no access to my Mac right now. And I'm not even certain that Finder doesn't somehow jump on AFP anyhow.

Edit: Ok, I can understand that you don't like to do the clicky-clicky every time. Here's a description of how to set your OSX account preferences to do the SMB mount for you at login: http://www.howtogeek.com/howto/21600/mount-a-windows-share-in-os-x-and-have-it-reconnect-at-login/

-and here's a slightly more technical recipe for making OSX automatically mount the SMB shares when needed by editing the fstab: https://superuser.com/questions/336665/how-to-automount-smb-shared-network-drives-in-mac-os-x-lion

Regarding priority, Apple says (http://support.apple.com/kb/HT5884) that in Mavericks SMB is the default protocol, and if not available, it will fall back to using AFP. This seems contrary to your experience, which makes me think that maybe you upgraded from Mountain Lion, and somehow the (hidden) setting of file protocol prioroty didn't get changed according to spec.

The link also says how to force a specific protocol:

To connect to a file server directly, use the Connect To Server feature of the Finder. Select Go > Connect To, and enter a URL, IP address or DNS name.

You can attempt to force a specific connection protocol (such as SMB or AFP) by using a valid URL. As long as the server you are connecting to allows the protocol you specify, the URL should work.

smb://ServerName/ShareName

afp://DOMAIN;User@ServerName/ShareName

Same disclaimer as above - I am only on 10.8, so everything might have changed in Mavericks.

  • This is correct. If you specify smb:// then the Finder will connect via Samba – Josh Dec 5 '13 at 15:24
  • I don't want to manually mount the drives every time I need them. I have updated the question. – gbrandt Dec 5 '13 at 16:14
  • You'll need to. The sidebar shows auto-detected AFP shares. Just add it as a login item if you want it mounted for you, or have a look at automounts – Josh Dec 5 '13 at 18:26
  • If I only have SMB2 enabled I still see the shares in the sidebar and they auto mount as SMB2, so somewhere there is a priority setting. – gbrandt Dec 6 '13 at 3:11
  • Odd ... The ars review says that default behavior of 10.9 is to use SMB2. arstechnica.com/apple/2013/10/os-x-10-9/22 – Kent Dec 6 '13 at 11:52
0

If you used to mount your disk using AFP just think about erasing the "Keychain item" accordingly… And as explained by use cmd - K from the Finder and type smb://serverAddress/sharedFolder

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .