4

I have just got a new iMac 14.3 with 21.5″ display. It has Intel i7 processor and NVIDIA GeForce GT750M graphics card with GPU (Device ID: 0x00fe9). I have installed Ubuntu 13.10 on it (dual boot with refit). Everything works fine apart from graphics. It is clear that graphics' not accelerated. I have tried to…

  1. Install NVIDIA drivers from the repository.
  2. Download NVIDIA drivers and install them manually.
  3. Follow instructions here.
  4. Follow instructions here.
  5. Follow instructions here.
  6. Install bumblebee.
  7. Play around with xorg.conf file.
  8. Blacklist nouveau.

As you may guess, nothing worked. The weirdest thing is, that when I boot from a LiveCD, it picks up screen resolution and all the rest correctly, though when I install the system to my Hard Drive it clearly does not have proper drivers. I have checked it with lsmod and it seems that it pick up nouveau drivers in LiveCD mode — everything works fine then, but it does not in the install mode — get crap resolution. Also, I cannot load nouveau drivers manually. In case this is important, I have to boot with acpi=off option, as it does not boot otherwise. Does anyone have any suggestion how can I fix this graphics problem?

2

The solution is actually very simple: just boot with nolapic instead of acpi=off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .