0

I'm facing a problem with my Mac Mini with Mountain Lion.

When I changed my disk permission of Macintosh for everyone to no access my Mac crashed and and it's not restarting when I boot the Mac. It just stops after showing the Apple logo.

How can I fix this?

1
  • 1
    I'm tempted to say: "What did you expect?" Why did you try and change that? It's never wise to manually change the permission of system files/folders. See my answer for a solution.
    – Frizlab
    Nov 28 '13 at 11:57
2

If you just selected Macintosh HD and changed "everyone" to "No Access" and did not select "Apply to enclosed items", try to:

  1. Start up in single user mode by holding command-S on startup.
  2. Run mount -uw /. fsck -fy is not necessarily needed.
  3. Run chmod 755 /.
  4. Run reboot.

If that doesn't work, try to reinstall OS X from the recovery partition. It installs a new copy of OS X over the current installation while keeping user files and settings in place. It solved a problem I had where my Mac got stuck during the startup process. If nothing else works, try to erase and reinstall OS X, or erase the Macintosh HD partition (not the whole drive) from Disk Utility and then choose Reinstall OS X.

If you don't already have backups, try to save a disk image to an an external drive in Disk Utility on the recovery partition or copy files to an external drive in single user mode.

1

Try booting with the ⎇ Alt (aka. ⌥ Opt) key down. You should see one or two disk(s) visible, one of them being the Recovery Partition. Select it, your computer should boot (but not on your usual desktop).

From there, select Disk Utilities and try repairing permissions on your main disk. Try rebooting normally then, it should work.

If it's not enough, you should reboot on the recovery partition again and reinstall Mac OS X on your main disk (it won't erase your data; only the system).

2
  • the DISK Utilities showing that I cant repair the permission and the mac not detecting the Ethernet also
    – Optimus
    Nov 28 '13 at 12:17
  • The try reinstalling the system :) Don't forget passing all the updates once the system is reinstalled.
    – Frizlab
    Nov 28 '13 at 13:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .