Is Soundflower 1.6.6 compatible with Mavericks 10.9?

  • 1
    According to RoaringApps it should work. – Saaru Lindestøkke Nov 28 '13 at 14:42
  • @BartArondson you should post that as an answer to the question, not a comment. It's technically the most correct answer. Should get the green checkmark. – Ian C. Nov 28 '13 at 18:56
  • @IanC. Ok, will do. I just felt that Lri's answer already answered it pretty well, so another answer stating the same would not add much I thought. – Saaru Lindestøkke Nov 28 '13 at 21:39

11 Answers 11


I just fixed the latest code from cycling74's github (1.6.7) to build it and run it on Mavericks.

You can get it at https://github.com/crmne/Soundflower/releases

  • awesome. just installed, works great – Aidan Miles Sep 22 '14 at 21:54

at first I thought that no, doesn't work for me.

deeper investigation revealed that indeed it does work but somehow Mavericks install set the volume to 0, means all the streams were nullified. I spent at least 2h fighting this issue and finally found the setting in system Audio Devices (not system preferences)

  • THANK YOU for this! I've been banging my head against this issue for far too long under Mountain Lion, as have apparently dozens of other people, and there's all sorts of crazy going on in the forums. Who knew it could be as simple as "check the master fader"! (For future visitors, the place to look is /Applications/Utilities/Audio MIDI Setup, in the Audio window.) – Sean D. Jan 10 '14 at 21:30

I just tried installing Soundflower 1.6.6 on 10.9 and it does still work. I don't know if there are some compatibility issues, but if there were some major issues they'd probably have released a new version already.


If you check on RoaringApps you can see that Soundflower works fine on Mavericks. However, there's only one report stating that, so depending on your hardware configuration you might have a different experience.


Sorry to be the first negative, but for me it does not work. Soundflower itself is working, but Soundflowerbed keeps crashing as soon as you want to change any settings. Konsole gives this information:

Application Specific Information:
*** Terminating app due to uncaught exception 'NSRangeException', reason: '*** -[__NSArrayM objectAtIndex:]: index 16 beyond bounds [0 .. 15]'
terminating with uncaught exception of type NSException
abort() called

There's a lot more on that error report regarding several .dylibs, but mainly thats it. Probably has to do with upgrading from SnowLeopard instead of using a fresh install. So if you want to upgrade the same way (SL > MAV directly) be warned: If you had a working Soundflower installation on SL do not try to upgrade to 1.6.6b, it's not going to work. Just stay with whatever you have, it's running fine.

Uninstalling and reinstalling didn't do anything to solve the problem. At least i recreated SOundflower 1.4.4 and the according .kext file from a TimeMachine Backup which works fine now.


No - Soundflower has quit working for me in 10.9.5 using 1.6.7 version of Soundcloud. Worked before in Mavericks but now has a lot of audio feedback. When channeling clive, you can't understand what people are saying.

I use it sometimes to record a video that is on screen with Quicktime.

  • 1
    @grgarside I've made a substantial edit to turn this in to a good report on what versions and what's wrong specifically with the app. It could be another question (possibly) but keeping all the data here seems to be best for people looking for options. – bmike Sep 23 '14 at 19:05

The best answer is Yes and No, it works completely but it causes lag when changing the volume. It can also send pretty cad digital to other apps so better to go without for that and use JackOSX.


I finally found that Soundflower has to be selected as both input and output for it to work properly in Quicktime screen recordings. Once I figured that out, it worked excellently.


Just use an old version of SoundFlower (for example SoundFlower 1.6.5) on Mavericks.


1.6.7 does not work in OS X 10.10.2. It crashes on start up with:

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Invalid parameter not satisfying: (index >= 0) && (index < [_itemArray count])'
terminating with uncaught exception of type NSException
abort() called

Just wanted to chime in. I use SimCap with Soundflower a lot to make demo videos of apps and I haven't been able to get audio to work at all since upgrading to Mavericks. When I've tried SoundFlower with other apps I get similar results. I have both input and output selected for Soundflower in the "Sound" section of System Preferences and both are set to about mid-volume.

  • Hi and welcome to Ask Different. Posting in the answers section is specifically reserved for posting direct answers to the question being asked. The Stack Exchange Q&A format is different from your typical forum, it's not meant for discussion. For more information please see our Help section. Consider deleting this as it will likely continue to attract down votes for not being a direct answer to the question or improving it to be a direct answer. – Ian C. May 7 '14 at 0:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .