0

I have looked everywhere, but the command defaults write com.apple.finder AppleShowAllFiles TRUE killall Finder and all variations thereof does not work since I upgraded to Mavericks. Why is this?? Any advice would be greatly appreciated. All advice for 10.8 does not seem to carry over to this new OS

5

It worked for me in 10.9. You should be using -bool TRUE (not just TRUE), although it worked for me either way. Also, are you running it as two commands (killall Finder is a second command)? The only other thing I can think of is that cfprefsd might have the old setting (or lack therof) cached, so you may have to shut it down it first. If I understand the setup right, that shouldn't be necessary, but just in case:

killall cfprefsd
defaults write com.apple.finder AppleShowAllFiles -bool TRUE
killall Finder
  • FWIW /usr/bin/defaults write com.apple.finder AppleShowAllFiles TRUE && killall Finder and /usr/bin/defaults write com.apple.finder AppleShowAllFiles FALSE && killall Finder are also definitely working for me on 10.9.0 – TJ Luoma Dec 1 '13 at 7:37
2

To answer your question, you can also use YES or NO as the boolean flags (See below). I have been using this setup for a few years now, and it does also work in Mavericks.

I have my computer setup such that I created an Automator workflow that runs the following shell script:

STATUS=`defaults read com.apple.finder AppleShowAllFiles`
if [ $STATUS == YES ]; 
then
    defaults write com.apple.finder AppleShowAllFiles NO
else
    defaults write com.apple.finder AppleShowAllFiles YES
fi
killall Finder

I then used the Keyboard shortcuts panel in System Preferences to map a keyboard shortcut to this automator workflow to make it even faster.

The only downside to this method is that if you have a Finder window already open, it doesn't always reopen the Finder windows, but it's a much quicker way of enabling/disabling the showing of hidden files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .