For years, I've used screen sharing to connect my MacBook to my iMac. It has always worked like a charm. About a month ago, it stopped working. I can still see my iMac in Finder when I'm on the laptop. But when I try to connect, I get the "busy" bar for a minute or two, then a message telling me I needed to enable screen sharing on the iMac.

Screen sharing is enabled; I never changed the setting, and I've double checked that it is still clicked. I can screen share via my MacBook with my husband's iMac across our home network, so I think the problem rests with the iMac, not with my laptop. I have tried sharing via VNC. I have tried logging out of Mobile me on the laptop. I have tried a screen sharing app. Nothing works. Can anyone think of anything I haven't tried?

I'm running OS X 10.7.5 on the iMac.

  • 1
    A few questions...Have you upgraded the iMac you wish to share recently? Do you have the firewall enabled on the iMac, and if you (temporarily) turn it off, does screen sharing work?
    – binarybob
    Commented Nov 28, 2013 at 21:00

3 Answers 3


Go to System Preferences -> Security & Privacy -> Firewall -> Firewall Options and remove anything in the list box lower section that has to do with screen sharing. You can remove an item by highlighting it then clicking the minus button below the list. Click Ok.

Next go to System Preferences -> Sharing and uncheck Screen Sharing.

Reboot. I don't know why this is needed and I hate that it is, but it didn't work for me to do this without a reboot.

Then go back to System Preferences -> Sharing and recheck Screen Sharing.

  • Still the best solution for when screen sharing suddenly stops working. Thanks.
    – Eric Aya
    Commented Dec 6, 2017 at 19:45
  • I found this after it turned out that disabling the firewall made VNC screen sharing work. Commented Apr 8, 2020 at 13:27
  • 1
    Good to see Apple taking a leaf out of Microsoft's book. Both iOS and Macos now need regular rebooting to fix these spurious bugs. God forbid they might employ some decent programmers and some tech savvy management. At least they're making money 🙄
    – amergin
    Commented May 27, 2021 at 15:30

Check the settings for Remote Management under System Preferences -> Sharing -> Remote Management. For whatever reason, I had an update cause the same issue on my 10.7 machine, and Screen Sharing no longer worked anymore. Under Computer Settings, you can give it a password if you like. Checking Remote management should check the Screen Sharing box for you also.

  • 1
    Thanks for the suggestion! Unfortunately, it didn't work.
    – Laura
    Commented Nov 28, 2013 at 12:49

I've had Screen Sharing on the server side freeze up on me numerous times under Lion (10.7), leaving me unable to sign in to that machine for various reasons, including a login screen that I couldn't interact with and symptoms similar to yours. Restarting the machine appeared to be the fastest way to get it working again.

Since I moved my screen-shared machines to Mountain Lion and Mavericks, I've had no further problems. I suspect Lion's implementation of Screen Sharing is simply buggy.

  • 1
    Thanks! I'm planning to replace my iMac soon. Neither it nor my laptop have the power to run Mavericks. Perhaps this is the final straw. :-)
    – Laura
    Commented Nov 28, 2013 at 12:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .