18

I am having trouble setting up a Time Machine backup to a shared network drive. I have an external drive plugged into a MacBook Pro (MBP), and I want to use Time Machine to remotely back up a MacBook Air (MBA) to it. I followed the instructions in “Can Time Machine back up to an external HD connected to another Mac?” but Time Machine will not present the remote drive as an option.

  • The drive is formatted properly. I have an identical partition to which the MBP does a local Time Machine backup.
  • The drive is shared properly. In fact, the MBA can see and mount the remote drive. MBA mounting shared partition
  • However, the partition is not shown as a potential Time Machine drive. No TM disks available

Finder can see and access the drive, so why can't Time Machine? Is there a bit somewhere I can flip to tell Time Machine to see it?

  • have you run disk repair and permission repair on the external drive? – CML Dec 4 '13 at 21:36
  • I had not run disk repair, since the drive has been freshly erased and partitioned. But now I have; no errors were found. I cannot repair permissions as there are no system files on the drive. – Flavin Dec 5 '13 at 13:11
  • 1
    Have you seen pondini.org/TM/B1.html and pondini.org/TM/22.html? I don't see anything specific there that you seem to have missed, but I think poudini.org is a great resource for Time Machine troubleshooting and it's worth checking through the steps there. – Ashley Dec 8 '13 at 23:21

10 Answers 10

22
+50

When you click the "Options..." button in the File Sharing preferences, is "Share files and folders using AFP" enabled? Time Machine over the network requires AFP, so it won't work if only SMB is enabled.

You may also need to disable SMB. I am not exactly sure why this is the case, but sometimes the SMB share takes priority and Time Machine can't seem to see the AFP share. Note that this will prevent Windows clients from connecting to file shares.

Options panel

  • Yes, AFP sharing was enabled. I hadn't checked that box myself, so I imagine it is on by default. – Flavin Dec 5 '13 at 13:12
  • 3
    Can you try disabling SMB sharing? Some people have suggested it might make a difference. – gabedwrds Dec 11 '13 at 14:37
  • 1
    That did it. I disabled SMB sharing on the MBP (while keeping AFP sharing enabled) and the MBA disconnected itself from the shared drive. I reconnected the MBA to the drive, and it was shown as an available TM disk. – Flavin Dec 11 '13 at 23:18
  • 2
    I've selected your answer as "correct". But in the interest of posterity, could you edit your answer to include disabling SMB sharing? – Flavin Dec 11 '13 at 23:32
  • you don't need to disable SMB, just connect to the server using afp (Finder -> Go -> Connect to Server "afp://some_server.local" and open the drive to backup to. It will become available in Time Machine – csanchez Jul 29 '15 at 8:34
7

I know its an old post, but hopefully this will help anyone looking into the issue. Disabling SMB will work, but isn't necessary. OS X now uses SMB as the default connection (see here: http://www.cnet.com/news/os-x-mavericks-switches-to-smb2-networking/), and SMB doesn't work with Time Machine. You can either disable SMB, thus forcing the mac to connect with AFP, or you can use the Finder 'Connect to Server' button under the Go menu, and force AFP as the protocol. I.e. afp://myserver.domain Tested under Yosemite 10.10.3

5

Because your Shared drive is not a TimeMachine enabled shared volume.

TimeMachine have special requirements using AFP as pointed out by gabedwrds thus thoses (eg. AFP Replay Cache) are not necessarily included with "OSX Client".

You should enable a "TimeMachine Server" in order to share an external disk accross the network.

You may try using the Terminal if you are not prepared to buy "Server.app". But you're talking about data backup therefore you want to be sure about consistency and recoverability ! Other backup solutions such as the excellent "Carbon Copy Cloner can achieve this without the "Server.app" and you may get free of charges similar results by using the rsync command from the terminal or using Automator.app…

If you don't care about using an unsupported solution and you are willing to take the risk of being in the so called "poo" :

• Either show unsupported network volumes :

defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

And then have a look in your TimeMachine system preferences…

• Or inputing the shared volume name manually therefore in your case type in the terminal :

sudo tmutil setdestination /Volumes/MBA\ TM

Then start your first backup :

tmutil startbackup

How to make Time Machine backups over network without OS X server?

  • 4
    FYI, the special requirement of Time Machine over LAN is certain AFP features, not hardlinks (it always uses a sparsebundle so hardlinks are hidden from the server). The specific requirements are listed here. A server running OS X should support all these features but might fail to advertise or be detected as Time Machine-capable. – gabedwrds Dec 11 '13 at 14:41
  • Good to know thanks ! But I bet this will somehow change with the next OS release (SMB2 being default on Mavericks). – llange Dec 11 '13 at 15:26
  • Now SMB3 with the latest Server.app in Yosemite… If someone knows : I still haven't checked if the last 2 systems uses SMB or not while performing TimeMachine backups. – llange Jan 14 '15 at 21:41
  • The latest Mac OS allows TimeMachine backups over SMB, Synology for instance do offer with the actual DSM to use it thus allowing to shut down AFP service when no longer required. Anyhow it seems that with 10.12.2 some bugs have been corrected in order for TM to work with TimeCapsules but it prohibits some users to open files directly from the Shared Folder. – llange May 21 '17 at 12:54
2

Our situation was that Time Machine could not see an SMB-attached drive even though the SMB drive contents could be otherwise accessed from that same MAC.

Today I was able to have a Time Machine backup created but by using Apple Filing Protocol (AFP), not SMB.

To do this, I took the following steps:

  1. Turn off Time Machine using system preferences, Time Machine, unclick “Back Up Automatically”

  2. Disconnect from the SMB-attached network drive

  3. Clean out the keychain of all “Time Machine” references using Keychain Access. Make sure you look in Category "All Items" and delete from Keychains under "login", "System" and "Local Items" all keychain entries related to:

    • the IP address of the SMB-attached drive
    • the name of the SMB-attached drive
    • the words "Time Machine"
    • the word "sparcebundle"
  4. Try to create a Time Machine backup using SMB:

    • Using a Finder window: Go, Connect to Server
    • In the Server Address box, type in "smb://aaa.bbb.ccc.ddd" where aaa.bbb.ccc.ddd is the IP address of the network-attached storage.
    • Using Time Machine Preferences and hit the "Select Disk" button
    • If the SMB-attached drive is visible, then select that drive.
    • If applicable, select to encrypt the backup
    • If the backup is made, then you are done
  5. But if Step 4 was not successful, try to create a Time Machine backup using AFP (Apple File Protocol):

    • Redo steps 1, 2, 3, and 4
    • Using a Finder window: Go, Connect to Server and in the Server Address box, type in "afp://aaa.bbb.ccc.ddd" where aaa.bbb.ccc.ddd is the IP address of the network-attached storage
    • Using Time Machine Preferences and hit the "Select Disk" button
    • If the AFP-attached drive is visible, then select that drive.
    • If applicable, select to encrypt the backup
    • If the backup is made, then you are done

We now have a backup created using AFP and although it is not a sparcebundle it seems to be running fine. At some point in the future, I plan to disconnect from the network-attached storage and reconnect to it with SMB as it is my understanding that SMB is current Apple protocol choice for creating a Time Machine backup over a network.

If anyone knows what might be the root problem on why AFP was successful and SMB was not, I would appreciate some advice.

  • This is what worked for me today. Thanks for sharing this. – Thibaut Barrère Sep 4 '17 at 19:46
1

I've had this problem before. I was able to connect the drive directly and perform a backup. Once the backup was completed, I added the drive back to the network and mounted it remotely and my Mac could then start backing up to it.

I'm not sure why this worked, only that it did work.

  • The guides I have seen (such as this one) state that once you get the network TM backup started, you can connect the remote drive directly and continue the backup that way for speed, then remove it and continue backing up over the network. But they say the initial setup needs to be over the network because TM stores the sparse bundles of local and network backups differently. – Flavin Dec 11 '13 at 17:38
1

I have just resolved my issue. My wireless has both 2.4Ghz and 5.0Ghz.

My iMac that has shared drive Time Machine sits in 5.0Ghz. My MacBook Pro was at 2.4Ghz. That's why it couldn't find it.

  • Interesting. I have a similar network. I'll have to check which bands the two machines are on and see if this caused my problem. – Flavin Nov 27 '14 at 21:44
1

Make sure you are sharing with write access for the particular user you are logging into the remote machine as.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

0

I had this exact issue with a Western Digital MyCloud drive. I had to log into the drive and go to the "Settings" tab. At the bottom there is an On/Off switch under "Mac Backups". I clicked the "Configure" button to the right and selected the folder I wanted to enable. Works fine now!

0

I found most of the above solutions too complicated. Here's what I did:

  1. Went to Finder/Go/Connect to Server
  2. In the Server Address box, typed in afp://xxx.xxx.x.xxx (where x was the address of my Synology DS1815 NAS) and hit the "+" button to add it as a Favorite Server
  3. Returned to Time Machine Preferences and hit the "Select Disk" button
  4. Chose the Synology NAS which was now visible
-1

I have had the same problem with my new Mac (Mavericks). There are lots of solutions on the internet which seem to work for other people and which I tried with no success. In case it helps this one did it for me. http://rajiv.sg/blog/2012/11/19/configuring-os-x-mountain-lion-time-machine-to-work-with-cifs-smb-share/

  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. – nohillside Jan 9 '14 at 10:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .