When I'm trying to sync my iPad 4 (iOS7) using my Macbook (Mavericks) it stucks on the stage "Importing photos". It was syncing for more than 9 hours with absolutely no progress until I cancelled it. There are around 500 pictures to import.

The cord is good. USB port works well. I have the most recent iTunes, iPhoto. Already tried to rebuild iPhoto library. Nothing helps.

Please advice.

10 Answers 10


Deleting ~/Pictures/iPod Photo Cache and emptying the trash did the trick for me.

Just to be clear,

  • Quit itunes.
  • Go to your home folder in the Finder
  • Go to the pictures folder
  • Right mouse click on "iPhoto Library.photolibrary" and choose Show Package Contents
  • Move "iPod Photo Cache" to the trash.
  • Empty the trash.
  • Open itunes and run a sync
  • Add what if you don't have a folder called "iPod Photo Cache"?
    – Unsliced
    Mar 12, 2014 at 12:36
  • If you don't have one, then this solution won't work for you unfortunately. Double check where your sync is getting stuck... you may need to search elsewhere. Mar 14, 2014 at 15:26
  • When you are using Photos instead of iPhoto, delete ~/Pictures/Photos Library/iPod Photo Cache
    – Pascal
    May 25, 2016 at 22:06

executive summary: check to see if it's full

I've been having this problem a lot lately, with OSX 10.9 and iTunes 11 on a 4th gen iPod Touch with iOS 6. I think there are a few contributors in my case, that seem to combine to stall it, often at "importing photos" or "preparing items" in step 8 (will stall for hours until I kill it).

One issue is that when I plug it in, iPhoto opens to copy photos off. I think the coordination between iPhoto 9.5 and iTunes may be buggy. Sometimes there are no new photos, and iPhoto doesn't offer any particular path forward, so there's no way for me to tell it I'm done with the (non-)sync. Meanwhile, iTunes seems to be waiting.

Another issue is that there are a couple photos and a couple music tracks that it has trouble moving over; these all work fine on one side or the other (ie Mac can play the audio, iPod can view the photo). I've wondered if a wipe and restore might cure this, but haven't been willing to risk this yet (worried it might fail to restore the same way it fails to sync).

These combine to make sync'ing unreliable anyway, but I think my most recent troubles were triggered by a new issue: the iPod was completely full, and iTunes didn't know this. I was tipped off when it claimed insufficient space for a 21 MB app downloaded in iOS, and I checked the iOS settings/general/usage screen to see "0 bytes" listed free. It had been filled up by me downloading podcasts to it that weren't being deleted -- I resolved this by manually deleting a bunch of them, and after a variety of sync attempts after that finally got it to complete. Even after this, iTunes thinks there is 8 GB free but the device says 4 GB, so there's a disconnect there. The way iTunes and iOS 6 handle podcasts seems clunky and is likely a factor.


I would terminate the sync and use Image Capture to retrieve the photos.

You have a much faster import to get them to a folder and then you can also delete them and perhaps isolate one bad photo that hangs or just break up the transfer.

Once you have all the photos off, you could delete a problem photo or two or just clean up the camera roll and try syncing again in iTunes. You could also open iPhoto and do the import directly as it and Image Capture have a better interface for letting you know where the import process is hanging.


I repaired privileges with Disk Utility while iTunes and iPhoto were NOT running.

After this I could sync photos to my iPhone 5S with iOS 7.1 from my MacBook Pro with 10.9.2 with iTunes 11.1.5.

Tried all the other things like deleting the iPod cache folder in the Pictures folder, rebuild the iPhoto Database and all. These did not work and iTunes stranded on the "Importing Photos" step.

Hope this will help others!


I had to change to the ~/Pictures/iPhoto Library directory and then use the following command to remove the cache: rm -r iPod\ Photo\ Cache/

Use the tab expansion feature of the shell to get the above command line quickly by typing rm -r iP + [tab] to expand the command line.


Using the Disk Utility app and selecting Repair Disk is what I tried first and that worked perfectly.


Deleting iPod Photo Cache fixed the stuck sync for me. Note this did break the photo-syncing link between iTunes and my devices: I had to reenable Sync Photos for them, and confirm I wanted to replace the existing photo library on the device.

Apple bless removing the folder: http://support.apple.com/en-us/HT203156


Just solved a similar problem. I even didn’t have to remove the iPod Photo Cache permanently!

  1. The synchronization got stuck on Importing photos.

  2. I closed iTunes and iPhoto and moved the folder ~/Pictures/iPhoto Library/iPod Photo Cache to Trash.

  3. I opened iTunes and ran the synchronization. It was done in a moment, the synchronization of photos was disabled.

  4. I closed iTunes and Put back the removed folder.

  5. Opened iTunes and everything works fine.


The easier fix is to rebuild/repair the Photos library.

  1. Quit Photos, and experience the "closing library" hang; now, force quit. (Argh!)
  2. Hold down Cmd + Opt while relaunching Photos to repair the library.
  3. Successfully import your stuff.

Clear all flies not photos. And run again. And add more photos. No just clean up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .