13

Scrolling (with two fingers on the trackpad) in Preview.app (and TeXShop.app) annoyingly blurs PDF text and I would like to disable the over-compensating anti-aliasing. I like the anti-aliasing while not scrolling just fine.

The image below has two Cmd+Shift+3 screenshots from within Preview, the top half with two fingers still on the trackpad after scrolling, the bottom half after releasing them. The boxed snippets were manually enlarged in Photoshop.

Overcompensating anti-aliasing

I have disabled two-finger zoom and two-finger rotation in System Preferences > Trackpad, and unchecked "Use LCD font smoothing when available" in System Preferences > General.

I have also set various defaults values, to no avail (the values below are just one combination of many I've tried):

for domain in com.apple.CoreGraphics CoreGraphics -g
do
  echo $domain
  defaults read $domain | egrep -i 'scal|smooth|alias|scroll'
done
> com.apple.CoreGraphics
>     CGFontDisableAntialiasing = 1;
> CoreGraphics
>     CGFontDisableAntialiasing = 1;
> -g
>     AppleAntiAliasingThreshold = 128;
>     AppleFontSmoothing = 0;
>     AppleScrollAnimationEnabled = 0;
>     AppleScrollerPagingBehavior = 1;
>     AppleShowScrollBars = Always;
>     NSScrollAnimationEnabled = 0;
>     "com.apple.mouse.scaling" = "1.5";
>     "com.apple.trackpad.scaling" = "-1";

I would like for scrolling to always look like it does if I scroll slowly, and vertically. The ugly anti-aliasing (blurring) is most likely to happen if Preview registers any horizontal scroll (which is rarely intentional), and was more prevalent before I turned off the two-finder scroll.

  • I've found two ways to get around a document that do not produce this ugliness: 1) use the arrow keys, 2) use a mouse -- my Logitech Revolution MX scroll wheel never causes this. This is sub-optimal, though—I really like OS X's accelerated (friction) scrolling, just not its accentuated blurring. – chbrown Feb 21 '14 at 16:32
  • Not quite a solution but a sort of workaround — I just do quick zoom in/out (CTRL+-) and it resets the sharpness (and I use mouse so these occurrences are rare). – Siniša Šašić Aug 19 '14 at 7:52
1

I suspect the blurring of text is caused by a low-memory proxy being used to ensure high FPS during scrolling, especially on Retina machines, probably when using integrated Intel graphics.

Therefore I would suggest doing the following steps in the below sequence, in order to maximize available RAM and VRAM:

  • close all windows in all apps

  • quit all apps

  • disconnect any external monitors

  • close extra desktops in Mission Control

  • for machines with NVIDIA GPU, make sure your computer is plugged into the charger, or that Automatic Graphics Switching is turned off in Energy Saver

  • if on a non-Retina machine, set "Best for display" in the Displays settings

  • if on a Retina machine, set "Best (Retina)" in the Displays setting

  • restart the machine or open Terminal and type "sudo purge", the hit enter, then quit Terminal

Note: the purge command takes a minute or two to finish. I've found it can really help to clear up RAM. Restarting does the same thing. Sometimes RAM does not automatically get freed up like it's supposed to without these steps, at least on 10.8.5 and earlier. It may not apply to 10.9 and newer, but it can't hurt to try.

If you would please, both before and after completing the above steps, open Activity Monitor and take note of how much memory, CPU, and disk data per second is being used. Post your before/after figures for Physical Memory and Memory Used in the comments (or Free memory if it shows that). Also let us know if the steps resolved your issue.

0

This isn't a complete answer, but I read before that you could fix this by going to System Preferences > General and changing Show Scrollbars to "When Scrolling." It seemed to work when I did it, but since then I've noticed it again, so it might not actually solve the problem. It does seem to have to do with it, though.

  • I had that set to "Always" previously, and can't discern any improvement (or degradation, for that matter) after setting it to "When Scrolling." – chbrown Feb 28 '14 at 17:04
0

I think CommaToast has the right idea. OS X is probably using a lower quality rendition of the content when scrolling, to ensure that it can move quickly and smoothly, then refining the image once you are done scrolling. I have absolutely no proof of this, but this type of behavior was extremely evident in early versions of iOS. Apple loves image quality, but they love providing flawless interaction even more.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .